UVALive 2038 Strategic game (树形DP,4级)

L - Strategic game
Crawling in process... Crawling failed Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Appoint description:

Description

Download as PDF

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:

the solution is one soldier (at the node 1).

Input

The input file contains several data sets in text format. Each data set represents a tree with the following description:
  • the number of nodes
  • the description of each node in the following format:
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifiernumber_of_roads
    or
    node_identifier:(0)
The node identifiers are integer numbers between 0 and n-1, for n nodes ( 0 < n ≤ 1500). Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers).

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2
思路:简单树形DP dp[u][0]不选dp[u][1]选。
     dp[u][1]+=min(dp[v][0],dp[v][1])
     dp[u][0]+=dp[v][1];
数据生成器
#include<iostream>
#include<cstdio>
#include<cstring>
#include<ctime>
#include<cstdlib>
using namespace std;
bool vis[1600][1600];
int main()
{
  int n;
  memset(vis,0,sizeof(vis));
  for(int i=0;i<=1503;++i)vis[i][i]=1;
  srand((int)time(0));
  n=rand()%1500+1;printf("%d\n",n);
  int z=n;
  for(int i=0;i<n;++i)
  {
    int zz=rand()%100;
    if(z>zz)
    z-=zz;
    else zz=0;
    printf("%d:(%d)",i,zz);
    int k=0;
    for(int j=0;j<zz;++j)
    { while(k<n&&vis[i][k])++k;
      printf(" %d",k);vis[i][k]=vis[k][i]=1;
    }
     printf("\n");
  }
}

对拍程序
 
   
@echo off
:loop
 rand.exe>data.txt
 std.exe<data.txt>std.txt
 my.exe<data.txt>my.txt
 fc my.txt std.txt
 if not errorlevel 1 goto loop
 pause 
 goto loop

代码
#include<cstring>
#include<iostream>
#include<cstdio>
#define FOR(i,a,b) for(int i=a;i<=b;++i)
#define clr(f,z) memset(f,z,sizeof(f))
using namespace std;
const int mm=1502;
const int oo=0x3f3f3f3f;
int head[mm],edge;
int dp[mm][2];
class Edge
{
  public:int v,next;
}e[mm*mm];
void data()
{
  edge=0;clr(head,-1);
}
void add(int u,int v)
{
  e[edge].v=v;e[edge].next=head[u];head[u]=edge++;
}
int DP(int u,int fa,int yes)
{ int v;
  if(dp[u][yes]!=-1)return dp[u][yes];
  dp[u][yes]=yes;
  for(int i=head[u];~i;i=e[i].next)
  {
    v=e[i].v;
    if(v==fa)continue;
    if(yes)dp[u][yes]+=min(DP(v,u,0),DP(v,u,1));
    else dp[u][yes]+=DP(v,u,1);
  }
  return dp[u][yes];
}
int main()
{
  int n,a,b,m;

  while(~scanf("%d",&n))
  {
    data();
    FOR(i,1,n)
    {
      scanf("%d",&a);
      scanf(":(%d)",&m);
      FOR(j,1,m)
      {
        scanf("%d",&b);
        add(a,b);add(b,a);
        //cout<<a<<" "<<b<<endl;
      }
    }
    clr(dp,-1);
    int ans=min(DP(0,-1,0),DP(0,-1,1));
    printf("%d\n",ans);
  }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值