poj 1079 Cube Stacking(并查集)

Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 15705 Accepted: 5331
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source


思路:记录当前点集合的所有元素个数和当前点到根的距离,答案就是二者之差


#include<iostream>
#include<cstring>
using namespace std;
const int mm=100010;
class node
{
  public:int r,u,dis;
}g[mm];
int m;
void dataset()
{
  for(int i=0;i<mm;i++)
    g[i].r=i,g[i].u=0,g[i].dis=1;
}
int look(int z)
{
  if(z^g[z].r)///压缩
  {
    int p=g[z].r;
    g[z].r=look(g[z].r);
    g[z].u+=g[p].u;
  }
  return g[z].r;
}
void uni(int a,int b)
{
  int x=look(a);
  int y=look(b);
  g[y].r=x;
  g[y].u=g[x].dis;
  g[x].dis+=g[y].dis;
}
int main()
{ char s;int a,b;
  while(cin>>m)
  { dataset();
    while(m--)
    {
      cin>>s>>a;
      if(s=='C')
      {
        b=look(a);cout<<g[b].dis-g[a].u-1<<"\n";
      }
      else {cin>>b;uni(a,b);}
    }
  }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值