Toys(思维 暴力)

Toys

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
在这里插入图片描述

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input
The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output
The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
Hint
As the example illustrates, toys that fall on the boundary of the box are “in” the box.

题意:按顺序给出隔板的数量n(下方把隔板看成线),每个隔板把一个区域分成两个,玩具的坐标(即点),箱子的区域(给的是左上角坐标和右下角坐标);然后n个隔板,m个玩具;输出每个区域的玩具数量;
思路:判断玩具(点)在隔板(线)的左边,还是右边

#include<stdio.h>
#include<string.h>
double a[10100],b[10100];
int c[10100];
int main(){
	double x1,y1,x2,y2,x,y;
	int n,m,i,j;
	while(~scanf("%d",&n)&&n){
		memset(c,0,sizeof(c));//初始化 
		scanf("%d%lf%lf%lf%lf",&m,&x1,&y1,&x2,&y2);
		for(i=0;i<n;i++)
			scanf("%lf%lf",&b[i],&a[i]);//b[]上线横坐标,a[]下线横坐标		
		double k;
		for(i=0;i<m;i++){
			int h=1;
			scanf("%lf%lf",&x,&y);//x即点的横坐标,y即点的纵坐标 
			for(j=0;j<n;j++){//遍历n条线,判断前n(0~n-1)个区域			
				if(x<=a[j]&&a[j]<=b[j]){//若x<=a[]且a[]<=b[](即斜率>=0或不存在)则点必在此线左方区域 
					c[j]++;//将点存入j区域 
					h=0;//标记已找到 
					break;//判断成功后,跳出循环 
				}					
				if(x<a[j]&&a[j]>b[j]){//x<=a[]且a[]>b[](即斜率<0) 
					if(x<=b[j]){//若x不在a[],b[]所在的矩形区域内,则点必在此线左方区域
						c[j]++;
						h=0;
						break;
					}							
					k=(y1-y2)*(a[j]-x)*1.0/(a[j]-b[j])+y2;//计算a[],b[]确定直线上x所对应的纵坐标(k) 
					                                      //*注意y2不一定为0; 
					if(k>=y){//根据斜率,可比较纵坐标得出,点是否在此线左方区域
						c[j]++;
						h=0;
						break;
					}					    
				}			
				if(x>=a[j]&&x<b[j]&&a[j]<=b[j]){
					k=(y1-y2)*(x-a[j])*1.0/(b[j]-a[j])+y2;;//计算a[],b[]确定直线上x所对应的纵坐标(k)					                                     
					if(k<=y){//根据斜率,可比较纵坐标得出点是否在此线左方区域
						c[j]++;
						h=0;
						break;
					}					    
				}		
			}
			if(h)    c[n]++;//若未被标记(前n个区域没有),则点在第n+1个区域 
		}
		for(i=0;i<=n;i++)
			printf("%d: %d\n",i,c[i]);
		printf("\n");
	}
	return 0;
}

Toy Storage
变形题
未按顺序给出隔板(线),需要先排序,然后输出区域内有玩具且玩具数量相同的数量即可

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node{
	int b,a;
}q[10100];
bool cmp(node x,node y){
	return x.b<y.b;
}
int c[10100];
int main(){
	double x1,y1,x2,y2,x,y;
	int n,m,i,j;
	while(~scanf("%d",&n)&&n){
		memset(c,0,sizeof(c));
		scanf("%d%lf%lf%lf%lf",&m,&x1,&y1,&x2,&y2);
		for(i=0;i<n;i++)
			scanf("%d%d",&q[i].b,&q[i].a);
		sort(q,q+n,cmp);		
		double k;
		for(i=0;i<m;i++){
			int h=1;
			scanf("%lf%lf",&x,&y);
			for(j=0;j<n;j++){			
				if(x<=q[j].a&&q[j].a<=q[j].b){
					c[j]++;
					h=0;
					break;
				}					
				if(x<q[j].a&&q[j].a>q[j].b){
					if(x<=q[j].b){
						c[j]++;
						h=0;
						break;
					}							
					k=(y1-y2)*(q[j].a-x)*1.0/(q[j].a-q[j].b)+y2;
					if(k>=y){
						c[j]++;
						h=0;
						break;
					}					    
				}			
				if(x>=q[j].a&&x<q[j].b&&q[j].a<=q[j].a){
					k=(y1-y2)*(x-q[j].a)*1.0/(q[j].b-q[j].a)+y2;
					if(k<=y){
						c[j]++;
						h=0;
						break;
					}					    
				}		
			}
			if(h)    c[n]++;
		}
		printf("Box\n");
		sort(c,c+n+1);
		int p=1;
		for(i=0;i<=n;i++){
			if(c[i]==0) 
			    continue;
			if(c[i]!=c[i+1]){
				printf("%d: %d\n",c[i],p);
				p=1;
			}			    
			else
			    p++;
		}					
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值