HDU4493 UVA 465 sscanf和sprintf的使用

HDU4493:

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4493

题目描述:

Tutor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1544    Accepted Submission(s): 431


Problem Description
Lilin was a student of Tonghua Normal University. She is studying at University of Chicago now. Besides studying, she worked as a tutor teaching Chinese to Americans. So, she can earn some money per month. At the end of the year, Lilin wants to know his average monthly money to decide whether continue or not. But she is not good at calculation, so she ask for your help. Please write a program to help Lilin to calculate the average money her earned per month.
 

Input
The first line contain one integer T, means the total number of cases. 
Every case will be twelve lines. Each line will contain the money she earned per month. Each number will be positive and displayed to the penny. No dollar sign will be included.
 

Output
The output will be a single number, the average of money she earned for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign without tail zero. There will be no other spaces or characters in the output.
 

Sample Input
  
  
2 100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00
 

Sample Output
  
  
$1581.42 $100
 

Source

题目大意:求12个数的平均数,结果没有后缀0。

题解:结果要求四舍五入且去掉末尾的0,所以用sprintf转换成字符串形式处理比较方便。

代码:

/**
 * @author neko01
 */
#include <iostream>
#include <cstdio>
#include <string.h>
#include <cstring>
using namespace std;
int main()
{
    int t;
    double a[13];
    scanf("%d",&t);
    while(t--)
    {
        double sum=0;
        char s[15];
        for(int i=0;i<12;i++)
        {
            scanf("%lf",&a[i]);
            sum+=a[i];
        }
        sum=sum/12;
        sprintf(s,"%.2lf",sum);
        int l=strlen(s);
        if(s[l-1]=='0'&&s[l-2]=='0')
            s[l-3]='\0';
        else if(s[l-1]=='0')
            s[l-1]='\0';
        printf("$%s\n",s);
    }
    return 0;
}
UVA465

题目链接:http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=406

题目大意:判断加法或乘法的因子和结果与是否大于int

题解:以字符串形式输入,然后用sscanf转换成double型进行比较

代码:

/**
 * @author neko01
 */
#include <iostream>
#include <cstdio>
#include <stdlib.h>
using namespace std;
long long INF=2147483647;
char s1[1000];
char s2[1000];
char c;
int main()
{
    while(scanf("%s %c %s",s1,&c,s2)!=EOF)
    {
	double a,b;
	sscanf(s1,"%lf",&a);
        sscanf(s2,"%lf",&b);;
        printf("%s %c %s\n",s1,c,s2);
        if(a>INF)
        printf("first number too big\n");
        if(b>INF)
        printf("second number too big\n");
        if(c=='+')
        {
            if(a+b>INF)
            printf("result too big\n");
        }
        if(c=='*')
        {
            if(a*b>INF)
            printf("result too big\n");
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
基于微信小程序的家政服务预约系统采用PHP语言和微信小程序技术,数据库采用Mysql,运行软件为微信开发者工具。本系统实现了管理员和客户、员工三个角色的功能。管理员的功能为客户管理、员工管理、家政服务管理、服务预约管理、员工风采管理、客户需求管理、接单管理等。客户的功能为查看家政服务进行预约和发布自己的需求以及管理预约信息和接单信息等。员工可以查看预约信息和进行接单。本系统实现了网上预约家政服务的流程化管理,可以帮助工作人员的管理工作和帮助客户查询家政服务的相关信息,改变了客户找家政服务的方式,提高了预约家政服务的效率。 本系统是针对网上预约家政服务开发的工作管理系统,包括到所有的工作内容。可以使网上预约家政服务的工作合理化和流程化。本系统包括手机端设计和电脑端设计,有界面和数据库。本系统的使用角色分为管理员和客户、员工三个身份。管理员可以管理系统里的所有信息。员工可以发布服务信息和查询客户的需求进行接单。客户可以发布需求和预约家政服务以及管理预约信息、接单信息。 本功能可以实现家政服务信息的查询和删除,管理员添加家政服务信息功能填写正确的信息就可以实现家政服务信息的添加,点击家政服务信息管理功能可以看到基于微信小程序的家政服务预约系统里所有家政服务的信息,在添加家政服务信息的界面里需要填写标题信息,当信息填写不正确就会造成家政服务信息添加失败。员工风采信息可以使客户更好的了解员工。员工风采信息管理的流程为,管理员点击员工风采信息管理功能,查看员工风采信息,点击员工风采信息添加功能,输入员工风采信息然后点击提交按钮就可以完成员工风采信息的添加。客户需求信息关系着客户的家政服务预约,管理员可以查询和修改客户需求信息,还可以查看客户需求的添加时间。接单信息属于本系统里的核心数据,管理员可以对接单的信息进行查询。本功能设计的目的可以使家政服务进行及时的安排。管理员可以查询员工信息,可以进行修改删除。 客户可以查看自己的预约和修改自己的资料并发布需求以及管理接单信息等。 在首页里可以看到管理员添加和管理的信息,客户可以在首页里进行家政服务的预约和公司介绍信息的了解。 员工可以查询客户需求进行接单以及管理家政服务信息和留言信息、收藏信息等。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值