链接:http://poj.org/problem?id=1860
Currency Exchange
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 19696 | Accepted: 7032 |
Description
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges, and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.
Input
The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain 6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10
3.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 4.
Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.
Sample Input
3 2 1 20.0 1 2 1.00 1.00 1.00 1.00 2 3 1.10 1.00 1.10 1.00
Sample Output
YES
Source
Northeastern Europe 2001, Northern Subregion
题意:货币汇率交换,问最后钱可否增加
简单题解:其实就是求是否有环,这个是正环,因为类似于求的是最长路
bellman算法求解时是循环n-1次后还还能继续松弛,这样就说明存在环,那么也就是钱会增加
代码如下:
/**
* @author neko01
*/
//#pragma comment(linker, "/STACK:102400000,102400000")
#include <cstdio>
#include <cstring>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
using namespace std;
typedef long long LL;
#define INF 0x7fffffff
#define min3(a,b,c) min(a,min(b,c))
#define max3(a,b,c) max(a,max(b,c))
#define pb(a) push_back(a)
#define mp(a,b) make_pair(a,b)
#define clr(a) memset(a,0,sizeof a)
#define clr1(a) memset(a,-1,sizeof a)
const double eps=1e-8;
const double pi=acos(-1.0);
struct Edge{
int u,v;
double r,w;
Edge(int _u=0,int _v=0,double _r=0,double _w=0):u(_u),v(_v),r(_r),w(_w){}
};
vector<Edge>e;
double dist[105];
int n,m,s;
double v;
bool bellman()
{
for(int i=1;i<=n;i++) //初始化相反为最小值
dist[i]=0;
dist[s]=v;
for(int i=1;i<n;i++) //循环n-1次
{
bool flag=false;
for(int j=0;j<e.size();j++)
{
int u=e[j].u;
int v=e[j].v;
double r=e[j].r;
double w=e[j].w;
if(dist[v]<(dist[u]-w)*r)
{
dist[v]=(dist[u]-w)*r;
flag=true;
}
}
if(!flag)
return false;
}
for(int j=0;j<e.size();j++)
{
int u=e[j].u;
int v=e[j].v;
double r=e[j].r;
double w=e[j].w;
if(dist[v]<(dist[u]-w)*r)
return true; //有负环
}
return false; //无
}
int main()
{
cin>>n>>m>>s>>v;
for(int i=0;i<m;i++)
{
int u,v;
double r1,w1,r2,w2;
scanf("%d%d%lf%lf%lf%lf",&u,&v,&r1,&w1,&r2,&w2);
e.pb(Edge(u,v,r1,w1));
e.pb(Edge(v,u,r2,w2));
}
if(bellman())
puts("YES");
else
puts("NO");
return 0;
}