From Alvin

记录下自己编程时遇到的一些问题及自己对某些方面的一些看法。

Ubuntu环境下利用Python3+PyQt5+Eric6进行GUI编程


首先当然是要配置环境啦,这里特别感谢@ideber的文章,安装过程已经非常详细了。

 

原文地址:http://blog.csdn.net/idber/article/details/40076821


下面贴出一些我在安装过程中遇到的问题:


1.安装PyQt5时失败,提示:This version of PyQt5 and the commercial version of Qt have incompatible licenses.

网上都说开源版本有自带的GPL协议,我也不知道为什么这里还会有这一项提示,于是就只好向度娘求救啦,自然是功夫不负有心人

解决方法:在解压后的PyQt文件夹中找到configure.py文件并打开,将2590行之后的下面这一段代码注释掉就OK啦

    # Common checks.
    if introspecting and target_config.qt_licensee != 'Open Source' and ltype == 'GPL':
        error(
                "This version of PyQt5 and the commercial version of Qt have "
                "incompatible licenses.")


 

2.为保证PyQt5能够正常使用,安装前需配置依赖环境

<strong>解决方法</strong>:sudo apt-get install PyQt5-dev



3.同样,在安装Qscintilla2前也需配置相应环境

解决方法:sudo apt-get install libqscintilla2*

为了省事,我就不管三七二十一把相关的包都装上了


还有一些问题没来得及记录,不过度娘是万能的你懂的~.~

接下来就是愉快的编程啦~~


版权声明:本文为博主原创文章,未经博主允许不得转载。

 

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/neoalvin/article/details/49962397
个人分类: Python
上一篇C#学习笔记——控件篇
下一篇Python正则表达式学习小结
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭