python安装方法- 3.6.3版本

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/nerissa_lou/article/details/78300839

一、 官网下载安装包:
官网网址:https://www.python.org/
我下载的是3.6.3版本,如下图:
这里写图片描述
二、 安装安装包,
1、 直接双击运行
这里写图片描述
2. 选择Customize installation,一定要勾选Add_Python 3.6 to PATH,防止手工添加环境变量
这里写图片描述
3.选择安装的属性,Documentation、pip、tcl/tk and IDLE 必须安装,tcl/tk and IDLE是Python环境的开发环境窗口,pip用来安装numpy等package。
我是选择全部安装。
这里写图片描述
4.选择安装路径,记住安装路径后面安装numpy等package要用到。我是选择安装在D:\python\install下面。之后点击安装,等待安装完成即可。
这里写图片描述
5.测试是否安装成功,环境变量是否添加等。
5.1点击开始,输入cmd,点击Enter键,进入cmd编程环境,输入python,如图中显示则表示安装成功。
这里写图片描述
这里写图片描述
5.2如果未添加环境变量,则显示’python’不是内部或外部命令,也不是可运行的程序或批处理文件。
这里写图片描述
5.3查看及添加环境变量的方法:
控制面板—>高级系统设置—>高级—>环境变量—>新建—>输入变量名(N):PATH,输入变量值(Y):D:\python\install\Scripts\;D:\python\install\,D:\python\install\是python的安装路径。
这里写图片描述
三、 package安装
3.1下载安装包,网址:http://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy
一定要选择与Python版本和电脑版本一致的安装包,如我是Python3.6.3,电脑64位,则下载适合Python3.6版本,电脑64位的安装包。
我下载的安装包:
numpy-1.13.3+mkl-cp36-cp36m-win_amd64
statsmodels-0.8.0-cp36-cp36m-win_amd64.whl
numpy-1.13.1+mkl-cp36-cp36m-win_amd64.whl
matplotlib-2.1.0rc1-cp36-cp36m-win_amd64.whl
scipy-0.19.1-cp36-cp36m-win_amd64.whl
scikit_learn-0.19.0-cp36-cp36m-win_amd64.whl
sympy-1.1.1-py2.py3-none-any.whl
3.2将安装包存放到路径:D:\python\install\Scripts\
3.3cmd到D:\python\install\Scripts\路径下安装。
1)进入路径的方法:d:
cd D:\python\install\Scripts\
2)安装方法,下面语句需逐条执行,待安装完成一个后再安装另一个:
pip install pandas-0.20.3-cp36-cp36m-win_amd64.whl
pip install statsmodels-0.8.0-cp36-cp36m-win_amd64.whl
pip install numpy-1.13.1+mkl-cp36-cp36m-win_amd64.whl
pip install matplotlib-2.1.0rc1-cp36-cp36m-win_amd64.whl
pip install scipy-0.19.1-cp36-cp36m-win_amd64.whl
pip install scikit_learn-0.19.0-cp36-cp36m-win_amd64.whl
pip install sympy-1.1.1-py2.py3-none-any.whl
图片展示的是pandas-0.20.3-cp36-cp36m-win_amd64.whl的安装。
这里写图片描述
3)验证是否安装成功,打开IDLE,输入import pandas,不报错则表示安装成功,其他的做类似的验证。。
这里写图片描述
4)其他安装方法,该方法无需下载安装包
语句1:pip install –user jupyter pandas nose ggplot
如果语句1执行报错则执行语句2:
Python –m pip install –user jupyter pandas nose ggplot

5)注意事项:
sklearn安装要求numpy scipy matplotlib scikit_learn是同一个版本,且windows 上不能通过pip install –user安装scipy,所以numpy scipy matplotlib scikit_learn最好在网站(http://www.lfd.uci.edu/~gohlke/pythonlibs/#numpy)下载whl的安装包安装。

展开阅读全文

没有更多推荐了,返回首页