hd 1789 Doing Homework again

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11278    Accepted Submission(s): 6616


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

  先将分数由大到小排列,如果有分数相同的情况,再将截至日期由小到大排列。然后设出一个数组a[]来按照分数从高到低记录必须占用的日期,如果有空闲的日期则标记为1 ,若没有空闲的日期则舍弃这个分数

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct note{
	int T;
	int S;
}q[1010];
bool cmp(note a , note b)
{
	if(a.S != b.S)
	  return a.S > b.S;
	else
	   return a.T < b.T;
}
int main()
{
	int n , t , i , j;
	int a[1010];
	scanf("%d", &t);
    while(t--)
    {
    	scanf("%d", &n);
    	for(i = 0 ; i < n ; i++)
    	     scanf("%d", &q[i].T);
    	for(i = 0 ; i < n ; i++)
    	     scanf("%d", &q[i].S);
    	sort(q,q+n,cmp);
    	memset(a,0,sizeof(a));
    	int sum = 0;
    	for(i = 0 ; i < n ; i++)
    	{
    		for(j = q[i].T ; j >= 1 ; j--)
    		{
    			if(a[j] == 0)
    			{
    				a[j] = 1;
    				break;
				}
			}
    		if(j == 0)
    		   sum += q[i].S;
		}
		printf("%d\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值