并查集

The Suspects
Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 30182 Accepted: 14678
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output

4
1
1

并查集(union and find):
并查集是一种用来管理元素分组情况的数据结构,并查集可以高效的进行如下操作:

  1. find:查询元素a和b是否属于同一组。
  2. union :合并元素a和b所在的组,使其成为同一组。

用到的数据结构:

  1. int par[MAX_N]:数组par[x]表示的是x的父亲的编号。当par[x]=x时,x就是所在的树的根。
  2. int rank[MAX_N] : 表示的是树的高度。

具体操作:

  1. 初始化init:用n个节点表示n个元素。最开始时没有边,也就是说每个元素都是一棵树。
  2. 合并union:从一个组的根向另一个组的根连边,这样两棵树就变成了一棵,也就把两个组合并为一个组了,同时要注意改变rank(合并时如果两棵树的rank不同,哪么rank小的向rank大的连边)。
  3. 查询find : 为了查询两个节点是否属于同一组,我们需要沿着树向上走,来查询包含这个元素的树的根是谁。如果两个节点走到了同一个根,哪么就可以知道它们属于同一个组。

总结:
并查集抽象的树结构,但实际操作是两个一维数组!

	//尤其要注意这两个函数
	public static int find(int x) {
		if(par[x]==x) return x;
		else return par[x] = find(par[x]);
	}
	public static void union(int x,int y){
		//找到根!
		x = find(x);
		y = find(y);
		if(x==y) return ;//已经在一棵树上了,返回
		//合并
		if(rank[x]<rank[y]){//小的向大的连
			par[x] = y;
		}
		else{
			par[y] = x;
			if(x==y) rank[y]++;
		}
	}

import java.util.Scanner;

public class Main {

	public static int n,m;
	public static int[] par = new int[30010],rank = new int[30010];
	
	public static void init(){
		for(int i=0;i<n;i++){
			par[i] = i;
			rank[i] = 0;
		}
	}
	public static int find(int x) {
		if(par[x]==x) return x;
		else return par[x] = find(par[x]);
	}
	public static void union(int x,int y){
		//找到根!
		x = find(x);
		y = find(y);
		if(x==y) return ;//已经在一棵树上了,返回
		//合并
		if(rank[x]<rank[y]){//小的向大的连
			par[x] = y;
		}
		else{
			par[y] = x;
			if(x==y) rank[y]++;
		}
	}
	public static int count(){
		int ret = 1;
		for(int i=1;i<n;i++){
			if(par[0]==par[i]) ret++;
		}
		return ret;
	}
	public static void show(){
		System.out.println("Output par:");
		for(int i=0;i<n;i++){
			System.out.println(i+","+par[i]);
		}
	}
	
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		while(in.hasNext()){
			n = in.nextInt();
			m = in.nextInt();
			if(n==0&&m==0) break;
			//n个人,m组
			init();
			int M = m,k;
			while((M--)>0){
				k = in.nextInt();
				int x = in.nextInt(),y;
				for(int i=1;i<k;i++){
					y = in.nextInt();
					union(x, y);
				}
			}
			//注意,最后在这个地方对每个元素都要找到它的根,便于统计和0在一棵树上的到底有多少个
			for(int i=0;i<n;i++) find(i);
			//show();
			int ans = count();
			System.out.println(ans);
		}
	}

}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值