UsacoTraining Chapter1.4 Barn Repair

Barn Repair

It was a dark and stormy night that ripped the roof and gates offthe stalls that hold Farmer John's cows. Happily, many of the cows wereon vacation, so the barn was not completely full.

The cows spend the night in stalls that are arranged adjacent toeach other in a long line. Some stalls have cows in them; some do not.All stalls are the same width.

Farmer John must quickly erect new boards in front of the stalls,since the doors were lost. His new lumber supplier will supply himboards of any length he wishes, but the supplier can only deliver asmall number of total boards. Farmer John wishes to minimize the totallength of the boards he must purchase.

Given M (1 <= M <= 50), the maximum number of boards that canbe purchased; S (1 <= S <= 200), the total number of stalls; C (1<= C <= S) the number of cows in the stalls, and the C occupiedstall numbers (1 <= stall_number <= S), calculate the minimumnumber of stalls that must be blocked in order to block all the stallsthat have cows in them.

Print your answer as the total number of stalls blocked.

PROGRAM NAME: barn1

INPUT FORMAT

Line 1:M, S, and C (space separated)
Lines 2-C+1:Each line contains one integer, thenumber of an occupied stall.

SAMPLE INPUT (file barn1.in)

4 50 18
3
4
6
8
14
15
16
17
21
25
26
27
30
31
40
41
42
43

OUTPUT FORMAT

A single line with one integer that represents the total number of stallsblocked.

SAMPLE OUTPUT (file barn1.out)

25

[One minimum arrangement is one board covering stalls 3-8, one covering14-21, one covering 25-31, and one covering 40-43.]


题意:用m条长度任意的木板将奶牛棚封上,确保有牛的牛棚必须封上,使得木板总长度最小

题解:考虑只有一条木板的情况,则显然从最左边的牛棚封到最右边的牛棚。如果再增加一条,则将有牛的牛棚中间最大的空档断开,改用两块木板,这样可以确保浪费的木板最少

/*
ID: nflsjxc1
TASK: barn1
LANG: C++                 
*/
#include<bits/stdc++.h>

using namespace std;

int m,s,c;

int stall[205];
vector<int>minu;

int main()
{
	freopen("barn1.in","r",stdin);
	freopen("barn1.out","w",stdout);
	ios::sync_with_stdio(0);

	cin>>m>>s>>c;
	for(int i=1;i<=c;i++)
	{
		cin>>stall[i];
	}
	sort(stall+1,stall+c+1);
	
	for(int i=1;i<c;i++)
	{
		minu.push_back(stall[i+1]-stall[i]-1);//注意减1 
	}
	
	int ans=stall[c]-stall[1]+1;
	m--;
	sort(minu.begin(),minu.end());
	reverse(minu.begin(),minu.end());
	int pos=0;
	while(m&&pos!=minu.size())
	{
		ans-=minu[pos];
		pos++;
		m--;
	}
	cout<<ans<<'\n';
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值