hdu 6092 Rikka with Subset(多重背包)

119 篇文章 1 订阅
113 篇文章 1 订阅
题目链接:这里写链接内容

Rikka with Subset

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1647 Accepted Submission(s): 822

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has n positive A1−An and their sum is m. Then for each subset S of A, Yuta calculates the sum of S.

Now, Yuta has got 2n numbers between [0,m]. For each i∈[0,m], he counts the number of is he got as Bi.

Yuta shows Rikka the array Bi and he wants Rikka to restore A1−An.

It is too difficult for Rikka. Can you help her?

Input
The first line contains a number t(1≤t≤70), the number of the testcases.

For each testcase, the first line contains two numbers n,m(1≤n≤50,1≤m≤104).

The second line contains m+1 numbers B0−Bm(0≤Bi≤2n).

Output
For each testcase, print a single line with n numbers A1−An.

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.

Sample Input
2
2 3
1 1 1 1
3 3
1 3 3 1

Sample Output
1 2
1 1 1
Hint

In the first sample, A is [1,2]. A has four subsets [],[1],[2],[1,2] and the sums of each subset are 0,1,2,3 . So B=[1,1,1,1]

题目大意:给你一个数组的所有子集和的个数的一个数组,问你原数组是多少?

思路:背包问题,说着太麻烦了,请看代码(不是我不想说,只是不知道该怎么说)。

#include<stdio.h>
#include<string.h>

int a[60],b[10009],dp[10009];

int main()
{
    int n,m,t;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(dp,0,sizeof(dp));
        scanf("%d%d",&n,&m);
        for(int i=0;i<=m;i++)
            scanf("%d",&b[i]);
        dp[0]=1;
        int p=0;
        for(int i=1;i<=m;i++)
        {
            int x=b[i]-dp[i];//减去能用组合的方式得出的i,x为原数组中有多少个i.
            for(int j=0;j<x;j++)//多重背包
            {
                a[p++]=i;
                for(int k=m;k>=i;k--)//01背包,求出用
                    dp[k]=dp[k]+dp[k-i];//dp记录能用,k能用新得出的数组,组合出多少种。
            }
        }
        for(int i=0;i<p-1;i++)//新得出的数组
            printf("%d ",a[i]);
        printf("%d\n",a[p-1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值