题目链接:Problem Arrangement
Problem Arrangement
Time Limit: 2 Seconds Memory Limit: 65536 KB
The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.
There are N problems in the contest. Certainly, it’s not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of “interesting value” to the contest.
Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.
Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:
The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).
The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).
Output
For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output “No solution” instead.
Sample Input
2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4
Sample Output
3/1
No solution
题目大意:给你n*n的矩阵代表将第i个,放到第j个需要多少代价,(不能同行,也不能同列)问:代价超过M的情况有多少,输出a/b(答案要最简化),a代表一共有多少种方案,b代表有多少种代价超过M 的,没有就输出No solution.
思路:状压DP,刚学我只能说一下我的理解了。
首先遍历0-
2n−1
2
n
−
1
种的情况,代表当前的状态,从这个状态枚举可以到达的所有状态即可、
代码:
#include <cstdio>
#include <cstring>
const int N = 13;
int dp[1<<13][510];
int f[N];
int a[N][N];
void isit()
{
f[1]=1;
for(int i=2; i<N; i++)
f[i]=f[i-1]*i;
}
int gcd(int a,int b)
{
if(b==0)
return a;
else
return gcd(b,a%b);
}
int main()
{
int T,m,n;
scanf("%d",&T);
isit();
while(T--)
{
scanf("%d%d",&n,&m);
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
scanf("%d",&a[i][j]);
memset(dp,0,sizeof(dp));
dp[0][0]=1;
for(int i=0; i<=(1<<n); i++)
{
int tmp=0;
for(int j=1; j<=n; j++)
if(i&(1<<(j-1)))
tmp++;
for(int j=1; j<=n; j++)
{
if(i&(1<<(j-1))) continue;
for(int k=0; k<=m; k++)
{
if(k + a[tmp+1][j] >= m)
dp[i+(1<<(j-1))][m] += dp[i][k];
else
dp[i+(1<<(j-1))][k+a[tmp+1][j]] += dp[i][k];
}
}
}
if(dp[(1<<n)-1][m] == 0)
printf("No solution\n");
else
{
int tm = gcd(f[n],dp[(1<<n)-1][m]);
printf("%d/%d\n",f[n]/tm, dp[(1<<n)-1][m]/tm);
}
}
return 0;
}