1029: [JSOI2007]建筑抢修
Time Limit: 4 Sec Memory Limit: 162 MBSubmit: 1510 Solved: 611
[ Submit][ Status]
Description
小刚在玩JSOI提供的一个称之为“建筑抢修”的电脑游戏:经过了一场激烈的战斗,T部落消灭了所有z部落的入侵者。但是T部落的基地里已经有N个建筑设施受到了严重的损伤,如果不尽快修复的话,这些建筑设施将会完全毁坏。现在的情况是:T部落基地里只有一个修理工人,虽然他能瞬间到达任何一个建筑,但是修复每个建筑都需要一定的时间。同时,修理工人修理完一个建筑才能修理下一个建筑,不能同时修理多个建筑。如果某个建筑在一段时间之内没有完全修理完毕,这个建筑就报废了。你的任务是帮小刚合理的制订一个修理顺序,以抢修尽可能多的建筑。
Input
第一行是一个整数N,接下来N行每行两个整数T1,T2描述一个建筑:修理这个建筑需要T1秒,如果在T2秒之内还没有修理完成,这个建筑就报废了。
Output
输出一个整数S,表示最多可以抢修S个建筑。 数据范围: N<150000,T1
Sample Input
4
100 200
200 1300
1000 1250
2000 3200
100 200
200 1300
1000 1250
2000 3200
Sample Output
3
HINT
Source
贪心+堆。。
具体做法:
先取时限快完的,能取则取。
否则反正不能取,看看能不能将之前的一个认为换成它,减少nowtime
显然取t1最大的任务,用堆维护
有关class中cmp的写法;
先建一个类,成员为空。。。
只有一个函数cmp1_1(i,j) 返回bool值
这个东东适用于STL中不支持cmp()的坑爹情况
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<functional>
#include<iostream>
#include<cmath>
#include<cstring>
#include<cctype>
#include<ctime>
#include<queue>
#include<stack>
using namespace std;
#define For(i,n) for(int i=1;i<=n;i++)
#define Fork(i,k,n) for(int i=k;i<=n;i++)
#define Rep(i,n) for(int i=0;i<n;i++)
#define Forp(x) for(int p=pre[x];p;p=next[p])
#define MAXN (150000+10)
struct item
{
int t1,t2;
}a[MAXN];
class cmp1
{
public:
bool operator()(item a,item b){return a.t1<b.t1;}
};
bool cmp2(item a,item b){return a.t2<b.t2;}
priority_queue<item,vector<item> ,cmp1 > h;
int n;
int main()
{
// freopen("bzoj1029.in","r",stdin);
// freopen(".out","w",stdout);
scanf("%d",&n);
For(i,n) scanf("%d%d",&a[i].t1,&a[i].t2);
sort(a+1,a+1+n,cmp2);
// cout<<cmp1_1(a[1],a[n]);
// For(i,n) cout<<a[i].t1<<' '<<a[i].t2<<endl;
// h.push(a[1]),h.push(a[2]),h.push(a[3]),h.push(a[4]),cout<<h.top().t1<<endl;
int nowtime=0,ans=0;
For(i,n)
{
if (nowtime+a[i].t1<=a[i].t2) nowtime+=a[i].t1,ans++,h.push(a[i]);
else if (h.size())
{
item p=h.top();
if (nowtime-p.t1+a[i].t1<=a[i].t2&&p.t1>a[i].t1)
{
nowtime=nowtime-p.t1+a[i].t1;
h.pop();h.push(a[i]);
}
}
}
// cout<<nowtime<<endl;
cout<<ans<<endl;
return 0;
}