HDU3625(82/600)

A murder happened in the hotel. As the best detective in the town, you should examine all the N rooms of the hotel immediately. However, all the doors of the rooms are locked, and the keys are just locked in the rooms, what a trap! You know that there is exactly one key in each room, and all the possible distributions are of equal possibility. For example, if N = 3, there are 6 possible distributions, the possibility of each is 1/6. For convenience, we number the rooms from 1 to N, and the key for Room 1 is numbered Key 1, the key for Room 2 is Key 2, etc.
To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force, then repeat the procedure above, until all the rooms are examined.
Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You want to know what is the possibility of that you can examine all the rooms finally.
Input
The first line of the input contains an integer T (T ≤ 200), indicating the number of test cases. Then T cases follow. Each case contains a line with two numbers N and K. (1 < N ≤ 20, 1 ≤ K < N)
Output
Output one line for each case, indicating the corresponding possibility. Four digits after decimal point are preserved by rounding.
Sample Input
3
3 1
3 2
4 2
Sample Output
0.3333
0.6667
0.6250

Hint
Sample Explanation

When N = 3, there are 6 possible distributions of keys:

Room 1  Room 2  Room 3  Destroy Times

1 Key 1 Key 2 Key 3 Impossible

2 Key 1 Key 3 Key 2 Impossible

3 Key 2 Key 1 Key 3 Two

4 Key 3 Key 2 Key 1 Two

5 Key 2 Key 3 Key 1 One

6 Key 3 Key 1 Key 2 One

In the first two distributions, because Key 1 is locked in Room 1 itself and you can’t destroy Room 1, it is impossible to open Room 1.
In the third and forth distributions, you have to destroy Room 2 and 3 both. In the last two distributions, you only need to destroy one of Room 2 or Room

就是智障斯特兰数

#include<bits/stdc++.h>
using namespace std;
long long  s[21][21];
#define int long long 
main()
{
    s[1][1]=1;
    for(int a=1;a<=20;a++)
    {
        s[a][a]=1;
        for(int b=1;b<=a;b++)
        {
            if(a==b)continue;
            s[a][b]=s[a-1][b-1]+(a-1)*s[a-1][b];
    //      cout<<s[a][b]<<" ";
        }
//      cout<<endl;
    }
//  return 0;
    int T;
    cin>>T;
    while(T--)
    {
        int n,m;
        cin>>n>>m;
        long long qb=1;
        for(int a=1;a<=n;a++)qb*=a;
        long long cz=0;
        for(int a=1;a<=m;a++)cz+=s[n][a];
        for(int a=1;a<=m-1;a++)cz-=s[n-1][a];
    //  cout<<cz<<endl;
        if(n==1)cz=0;
        printf("%.4f\n",cz*1.0/qb);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值