HDU6092(83/600)

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has n positive A1−An and their sum is m. Then for each subset S of A, Yuta calculates the sum of S.

Now, Yuta has got 2n numbers between [0,m]. For each i∈[0,m], he counts the number of is he got as Bi.

Yuta shows Rikka the array Bi and he wants Rikka to restore A1−An.

It is too difficult for Rikka. Can you help her?

Input
The first line contains a number t(1≤t≤70), the number of the testcases.

For each testcase, the first line contains two numbers n,m(1≤n≤50,1≤m≤104).

The second line contains m+1 numbers B0−Bm(0≤Bi≤2n).

Output
For each testcase, print a single line with n numbers A1−An.

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.

Sample Input
2
2 3
1 1 1 1
3 3
1 3 3 1

Sample Output
1 2
1 1 1

这个题就是碰到的所有能碰的都算到答案里去
字典序那句话可以说是废话了
算进答案里的去筛掉不能算进答案里的

但是要从小的去筛掉大的

比赛的时候我妄图用大的筛掉小的结果发现组合数算不出来就gg了

#include<bits/stdc++.h>
using namespace std;
long long bi[10010];
int dan[10010];
int main()
{
    int T,n,m;
    cin>>T;
    while(T--)
    {
        memset(dan,0,sizeof(dan));
        cin>>n>>m;
        for(int a=0;a<=m;a++)scanf("%lld",&bi[a]);
        for(int a=0;a<=m;a++)
        {
            if(dan[0]>=n)break;
            if(a<1)continue;
            if(!bi[a])continue;
            dan[++dan[0]]=a;
            for(int b=a;b<=m;b++)
            {
                bi[b]=bi[b]-bi[b-a];
            }
            a--;
        }
        int jc=0;
        for(int a=1;a<=dan[0];a++)
        {
            if(!jc)
            {
                printf("%d",dan[a]);
                jc=1;
                continue;
            }
            printf(" %d",dan[a]);
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值