大慧博客

大慧的技术专栏

LINUX卸载RPM包装的HTTPD

     今天在VMWare上准备搭建下LMAP环境,看了下RPM包里装的APACHE的版本很老,是APACHE2.0版本的,这个版本对SSL的支持还不够好,所以要重装下,

     网上看了些文章,了解了下流程,

     1.第一步首先要检查下RPM包的依赖关系咯.

              查了下,检查依赖关系有俩重方法

        <1> shell>rpm -e --test httpd

             这个方法所检测的结果比较多,也比较详细

        httpd-mmn = 20020628 is needed by (installed) mod_perl-1.99_07-5
        httpd-mmn = 20020628 is needed by (installed) mod_python-3.0.1-3
        httpd-mmn = 20020628 is needed by (installed) mod_ssl-2.0.40-21
        httpd-mmn = 20020628 is needed by (installed) php-4.2.2-17
        libapr.so.0 is needed by (installed) mod_perl-1.99_07-5
        libaprutil.so.0 is needed by (installed) mod_perl-1.99_07-5
        webserver is needed by (installed) webalizer-2.01_10-11
        httpd >= 2.0.40 is needed by (installed) mod_perl-1.99_07-5
        httpd >= 2.0.40 is needed by (installed) mod_python-3.0.1-3
        httpd is needed by (installed) mod_ssl-2.0.40-21

      <2>shell>rpm -qa | grep httpd

        httpd-manual-2.0.40-21
        httpd-2.0.40-21

 

            这个方法分析出来的结果少,而且有些依赖关系根本没有显示,卸载的时候会报错误,网上看那位仁兄直接用--nodeps

         选项给屏蔽掉了,后果可想而知咯,向php4就没有卸载,系统残留好多垃圾,到时候想用都用不了,想卸都卸不干净,出问题

        是自然咯,所以推荐大家还是用第一种方法,但是为什么俩个命令会有这么大的差异,还请各位高手解答了,我刚以为是第

        二种方法是只查找已经加载到内存的模块,但是用ps 看了下,不是.

 

              另,-nodeps设置这里也是对的,有些模块有的是用户是想保留的,就可以用这个选项了,我感觉这个俩个命令的差别是

        一个是列出所有的和HTTPD服务相关的模块,而另一个则是只列出和HTTPD服务紧密相关的模块了,但是我觉得,我这些

       模块都差不多有个生存期,太老了,干脆都卸了吧,但是如果在一些很先进的服务器上,卸载的时候如果要有所保留的话,还是

       用第二种方法把,到时候直接把mod加入配置文件就能用了,(自认为,哈哈,错了不许丢我鸡蛋)

 

     2.检测出来了就可以挨个由低向上卸载了.其实是由最高一层的应用软件向下开始卸载.

 

   

  

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/nirvana52/article/details/3051102
想对作者说点什么? 我来说一句

apache httpd 2.4.26 for rhel7 x86_64 RPM

2017年08月18日 9.14MB 下载

没有更多推荐了,返回首页

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭