Floyed-MPI Maelstrom POJ - 1502

Floyed-MPI Maelstrom POJ - 1502

关于Floyed算法的一个问题-----k为何写在最外层?
在这里插入图片描述
说的什么意思呢
考虑第k个点来更新最短路的时候依赖于第k-1个点的状态,也就是说在考虑第k个点来更新i->j的最短路的时候,i->k的距离和k->j的距离应该已经是最短距离了。
Floyed算法的最外层是在枚举经过点k的所有i->j的的路径的最短距离。
题目:

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee’s research advisor, Jack Swigert, has asked her to benchmark the new system.
Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert.Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.’’

``How is Apollo’s port of the Message Passing Interface (MPI) working out?’’ Swigert asked.

Not so well,'' Valentine replied.To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.’’

``Is there anything you can do to fix that?’’

Yes,'' smiled Valentine.There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.’’

``Ah, so you can do the broadcast as a binary tree!’’

``Not really a binary tree – there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don’t necessarily arrive at the destinations at the same time – there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.’’
Input
The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.
Output
Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.
Sample Input
5
50
30 5
100 20 50
10 x x 10
Sample Output
35

题意:
1号计算机来传播信息到其他n-1台计算机(1号可以通过一定时间传播到与其相邻的其他计算机,其他计算机接收到信号后再继续传播),输入计算机数量n,输入下三角邻接矩阵(x指不连通即代价无穷大),求使得所有计算机均接收到信息的最短时间。

思路:
因为n<=100,考虑floyed算法,是一道模板题。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<stdlib.h>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn=105;
int n,a[maxn][maxn],ans=-inf;

int main()
{
    memset(a,inf,sizeof(a));
    cin>>n;
    for(int i=2;i<=n;i++)//下三角矩阵i从2开始
    {
        a[i][i]=0;//
        for(int j=1;j<i;j++)
        {
            char tmp[10];
            cin>>tmp;
            if(tmp[0]=='x') continue;
            else {a[i][j]=atoi(tmp);a[j][i]=a[i][j];}//atoi函数(char *),头文件stdlib.h
        }
    }
    for(int k=1;k<=n;k++)//k第一层,i第二层,j第三层的顺序
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                a[i][j]=min(a[i][j],a[i][k]+a[k][j]);

    for(int i=2;i<=n;i++)//一重循环找1到其他点的最短路的最大值即可,而不是找任意两点间的最大值
        if(a[1][i]!=inf)//找最大的d[i][j]但别忽略了无通路
            ans=max(ans,a[1][i]);//更新最大值
    cout<<ans;
    return 0;
}

总结:

  1. atoi函数(chag *),头文件stdlib.h
  2. floyed算法最外层是k层
  3. 更新最大值ans=max(ans,a[1][i]),同时注意不能忽略初始化无通路的权值inf
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值