HDU 1004 Let the Balloon Rise 多种方式的字符串比较

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 


Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
 
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
 
  
red pink


当时最直接的想法是先把字符串输入完,然后对他们按长度排个序,最后统计个数。明显,这不是最简便的,但这是一种办法。附上代码
#include<cstdio>
#include<iostream>
#include<string>
#include<algorithm> 
using namespace std;

int cmp(string s1,string s2)
{
	return s1.length()< s2.length();
}

int main()
{
	int n;
	string s[1002];
	while(cin>>n&&n)
	{
		for(int i = 0;i< n;i++)
			cin>>s[i];
		sort(s,s+n,cmp);
		int max = 0;
		string maxs;
		for(int i = 0;i< n;i++)
		{
			int t = 1;
			for(int j = i+1;s[i]==s[j];j++)
			{
				t++;i++;
			}
			if(t> max)
			{
				max = t;
				maxs = s[i];
			}
		}
		cout<<maxs<<endl;
	}
	return 0;
}
注意:这里的string不能写成cstring

还有一种方法,存储的字符串都不相同,每次输入字符串都遍历一遍现有的字符串,有相同的相同的那个+1,否则存储这个字符串。
看代码:
#include<cstdio>
#include<iostream>
#include<string> 
#include<cstring>
using namespace std;
int main()
{
string s[1002];
int num[1002];
int n;
while(cin>>n&&n)
{
memset(num,0,sizeof(num));
int sum = 0;
int max = 1;
int maxd = 0;
string temp;
while(n--)
{
cin>>temp;
int i;
for(i = 0;i< sum;i++)
{
if(temp == s[i])
{
num[i]++;
if(num[i]> max)
{
max = num[i];
maxd = i;
}
break;
}
}
if(i == sum)
{
s[sum++] = temp;
num[i]++;
}
}
cout<<s[maxd]<<endl;
}
return 0;
}


感觉逼格高了一丢,但是STL才真的厉害!这里map的用法是现学的,以后要多多学习这种高逼格的做法。
#include<iostream>  
#include<string>  
#include<map>  
using namespace std;  
map<string,int>M;  
map<string,int>::iterator p,q;  
int n;  
int main()  
{  
    string str;  
    while(scanf("%d",&n),n)  
    {  
       M.clear();
       while(n--)  
       {  
          cin>>str;  
          if(M[str]==0) 
            M[str]=1;  
          else   
              M[str]++;  
       }  
       int k=-1;  
       for(p=M.begin();p!=M.end();p++)
       {  
         if((p->second)>k)  
         {  
            k=p->second;  
            q=p;  
         }  
       }  
      cout<<q->first<<endl;   
    }  
    return 0;  
}  

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值