C - Let the Balloon Rise

C - Let the Balloon Rise

题目描述
有多种颜色的气球,统计它们的个数,并找出数量最多的那种颜色。

Input
有多组样例输入。每组样例第一行输入一个整数N (0 < N <= 1000) – 代表一共有N个气球。接下来N行每行输入一个不多于15个字母的字符串代表颜色。

N=0代表输入结束。

Output
每组样例数据输出数量最多的那种颜色的气球。(保证输出唯一)

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

用map即可轻松解决问题

代码:

#include <iostream>
#include<map>
#include<string>
#include<stdio.h>
using namespace std;
map<string,int>ball;
int main()
{
    int n;
    string s;
    map<string,int>::iterator it,itt;
    while(scanf("%d",&n)!=EOF){
            if(n==0)
            break;
            ball.clear();
    for(int i=0;i<n;i++){
        cin>>s;
        ++ball[s];
    }
    itt=ball.begin();
    for(it=ball.begin();it!=ball.end();it++){
        if(itt->second<it->second)
            itt=it;
    }
    cout<<itt->first<<endl;
    }
    return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值