HDU3980Paint Chain(尼姆博奕SG)

Paint Chain

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2051    Accepted Submission(s): 751


Problem Description
Aekdycoin and abcdxyzk are playing a game. They get a circle chain with some beads. Initially none of the beads is painted. They take turns to paint the chain. In Each turn one player must paint a unpainted beads. Whoever is unable to paint in his turn lose the game. Aekdycoin will take the first move.

Now, they thought this game is too simple, and they want to change some rules. In each turn one player must select a certain number of consecutive unpainted beads to paint. The other rules is The same as the original. Who will win under the rules ?You may assume that both of them are so clever.
 

Input
First line contains T, the number of test cases. Following T line contain 2 integer N, M, indicate the chain has N beads, and each turn one player must paint M consecutive beads. (1 <= N, M <= 1000)
 

Output
For each case, print "Case #idx: " first where idx is the case number start from 1, and the name of the winner.
 

Sample Input
  
  
2 3 1 4 2
 

Sample Output
  
  
Case #1: aekdycoin Case #2: abcdxyzk

题意:一个有n个物品的环,每次必须拿m个,谁没的拿谁就输了,问谁赢。

思路:当第一个人拿了一次之后就变成一条链了,此时用SG函数求解,对于前i(i>.= m)个,我们取连续m个,就是sg(i-m)^sg(n-i),这样递推求解。

整体值等于局部值的亦或。


#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cstring>
#include<string>
#include<vector>
#include<cmath> 
#include<map>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long ll;
const int maxn = 2e5+5;
const int ff = 0x3f3f3f3f;

int n,m;
int sg[1005],vis[1005];

int getsg(int x)
{
	mem(vis,0);
	for(int j = m;j<= x;j++)
		vis[sg[j-m]^sg[x-j]] = 1;
	for(int j = 0;;j++)
		if(!vis[j])
		{
			sg[x] = j;
			break;
		}
	return sg[x];
}

int main()
{
	int t,cnt = 0;
	cin>>t;
	while(t--)
	{
		scanf("%d %d",&n,&m);
		if(n< m)
		{
			printf("Case #%d: abcdxyzk\n",++cnt);
			continue;
		}
		n-= m;
		mem(sg,-1);
		for(int i = 0;i<= n;i++)
			sg[i] = i< m?0:getsg(i);
		if(sg[n] == 0)
			printf("Case #%d: aekdycoin\n",++cnt);
		else
			printf("Case #%d: abcdxyzk\n",++cnt);
	}	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值