ZOJ2770Burn the Linked Camp(差分约束+SPFA)

Burn the Linked Camp

Time Limit: 2 Seconds       Memory Limit: 65536 KB

It is well known that, in the period of The Three Empires, Liu Bei, the emperor of the Shu Empire, was defeated by Lu Xun, a general of the Wu Empire. The defeat was due to Liu Bei's wrong decision that he divided his large troops into a number of camps, each of which had a group of armies, and located them in a line. This was the so-called "Linked Camps".

Let's go back to that time. Lu Xun had sent many scouts to obtain the information about his enemy. From his scouts, he knew that Liu Bei had divided his troops into n camps, all of which located in a line, labeled by 1..n from left to right. The ith camp had a maximum capacity of Ci soldiers. Furthermore, by observing the activities Liu Bei's troops had been doing those days, Lu Xun could estimate the least total number of soldiers that were lived in from the ith to the jth camp. Finally, Lu Xun must estimate at least how many soldiers did Liu Bei had, so that he could decide how many troops he should send to burn Liu Bei's Linked Camps.

Input:

There are multiple test cases! On the first line of each test case, there are two integers n (0<n<=1,000) and m (0<=m<=10,000). On the second line, there are n integers C1···Cn. Then m lines follow, each line has three integers i, j, k (0<i<=j<=n, 0<=k<2^31), meaning that the total number of soldiers from the ith camp to the jth camp is at least k.

Output:

For each test case, output one integer in a single line: the least number of all soldiers in Liu Bei's army from Lu Xun's observation. However, Lu Xun's estimations given in the input data may be very unprecise. If his estimations cannot be true, output "Bad Estimations" in a single line instead.

Sample Input:

3 2
1000 2000 1000
1 2 1100
2 3 1300
3 1
100 200 300
2 3 600

Sample Output:

1300
Bad Estimations

题意:n个帐篷,m个描述,下面n个值代表每个帐篷最多能容多少人.下面m行表示区间[a,b]内最少有c人,问总共最少有多少人.

思路:一个很好的差分约束,让我又去认真翻看了某巨的讲解,从头到尾,醍醐灌顶.附链接

相当于给定m个不等式,以及题目隐藏不等式,用最短(长)路求出结果.

mark:题目有可能给出各种各样的不等式,需要求最小值化为>= 求最长路,求最大值则化为<= 求最短路.

这个题出现正权回路就说明无答案,当然也可以用前缀和的方式判断是否有答案.

代码:

#include<bits/stdc++.h>
#define mem(a,b) memset(a,b,sizeof(a))
#define mod 1000000007
using namespace std;
typedef long long ll;
const int maxn = 1e5+5;
const double esp = 1e-7;
const int ff = 0x3f3f3f3f;
map<int,int>::iterator it;

struct node
{
	int u;
	ll w;
	int v;
	int ne;
} r[maxn];

int n,m,len;
int head[maxn],vis[maxn],d[maxn];
ll dis[maxn];

void add(int u,int v,ll w)
{
	r[len].u = u;
	r[len].v = v;
	r[len].w = w;
	r[len].ne = head[u];
	head[u] = len++;
}

bool spfa()
{
	queue<int> q;
	q.push(0);
	dis[0] = 0;
	vis[0] = 1;
	d[0]++;
	
	while(!q.empty())
	{
		int pos = q.front();
		q.pop();
		vis[pos] = 0;
		for(int i = head[pos];i!= -1;i = r[i].ne)
		{
			int to = r[i].v;
			if(dis[pos]+r[i].w> dis[to])
			{
				dis[to] = dis[pos]+r[i].w;
				if(!vis[to])
				{
					q.push(to);
					d[to]++;
					
					if(d[to]>= n)
						return 0;
				}
			}
		}
	}
	
	return 1;
}

void init()
{
	len = 0;
	mem(head,-1);
	mem(vis,0);
	mem(d,0);
	mem(dis,-1);
}

int main()
{
	while(~scanf("%d %d",&n,&m))
	{
		init();
		for(int i = 1;i<= n;i++)
		{
			int c;
			scanf("%d",&c);
			add(i,i-1,-c);
			add(i-1,i,0);
		}
		
		for(int i = 1;i<= m;i++)
		{
			int a,b,c;
			scanf("%d %d %d",&a,&b,&c);
			add(a-1,b,c);
		}
		
		if(spfa())
			printf("%lld\n",dis[n]);
		else
			printf("Bad Estimations\n");
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值