ZOJ 2770 Burn the Linked Camp(裸差分约束)

ZOJ 2770 Burn the Linked Camp(裸差分约束)

ZOJ 2770

Burn the Linked Camp

Time Limit: 2 Seconds Memory Limit: 65536 KB
It is well known that, in the period of The Three Empires, Liu Bei, the emperor of the Shu Empire, was defeated by Lu Xun, a general of the Wu Empire. The defeat was due to Liu Bei's wrong decision that he divided his large troops into a number of camps, each of which had a group of armies, and located them in a line. This was the so-called "Linked Camps".

Let's go back to that time. Lu Xun had sent many scouts to obtain the information about his enemy. From his scouts, he knew that Liu Bei had divided his troops into n camps, all of which located in a line, labeled by 1..n from left to right. The ith camp had a maximum capacity of Ci soldiers. Furthermore, by observing the activities Liu Bei's troops had been doing those days, Lu Xun could estimate the least total number of soldiers that were lived in from the ith to the jth camp. Finally, Lu Xun must estimate at least how many soldiers did Liu Bei had, so that he could decide how many troops he should send to burn Liu Bei's Linked Camps.

Input:

There are multiple test cases! On the first line of each test case, there are two integers n (0<n<=1,000) and m (0<=m<=10,000). On the second line, there are n integers C1��Cn. Then m lines follow, each line has three integers i, j, k (0<i<=j<=n, 0<=k<2^31), meaning that the total number of soldiers from the ith camp to the jth camp is at least k.

Output:

For each test case, output one integer in a single line: the least number of all soldiers in Liu Bei's army from Lu Xun's observation. However, Lu Xun's estimations given in the input data may be very unprecise. If his estimations cannot be true, output "Bad Estimations" in a single line instead.

Sample Input:

3 2
1000 2000 1000
1 2 1100
2 3 1300
3 1
100 200 300
2 3 600

Sample Output:

1300
Bad Estimations
题意:刘备有n个兵营,每个兵营有最多容纳Ci个士兵,陆逊有m条估计,从第i到j的兵营至少有k个士兵
分析:每个兵营有0 <= s[i] - s[i - 1] <= c[i]
陆逊的判断,s[i] - s[j - 1] >= k;所以根据不等式,可以用最长路做

AC代码:
#include<bits/stdc++.h>
using namespace std;
const int N = 1e5+10;
const int inf = 0x3f3f3f3f;
struct node{
    int u, v, w, nxt;
}edge[N];
int n, m, cnt;
int fir[N], dis[N], num[N];
bool vis[N];
inline void built(int u, int v, int w){
    edge[cnt] = (node){u, v, w, fir[u]};
    fir[u] = cnt++;
}
inline int spfa(int st){
    memset(vis, false, sizeof(vis));
    vis[st] = true;
    memset(num, 0, sizeof(num));
    num[st]++;
    for(int i = 0; i <= n; i++){
        dis[i] = -inf;
    }
    dis[st] = 0;
    queue<int> Q;
    Q.push(st);
    while(!Q.empty()){
        int u = Q.front();
        Q.pop();
        vis[u] = false;
        for(int i = fir[u]; i; i = edge[i].nxt){
            int v = edge[i].v;
            if(dis[v] < dis[u] + edge[i].w){
                dis[v] = dis[u] + edge[i].w;
                if(!vis[v]){
                    vis[v] = true;
                    Q.push(v);
                    num[v]++;
                    if(num[v] >= n)
                        return -1;
                }
            }
        }
    }
    return dis[n];
}
int main(){
    #ifdef ONLINE_JUDGE
    #else
        freopen("in.txt", "r", stdin);
    #endif // ONLINE_JUDGE
    int a, b, c;
    while(~scanf("%d%d", &n, &m)){
        memset(fir, 0, sizeof(fir));
        cnt = 1;
        for(int i = 1; i <= n; i++){
            scanf("%d", &a);
            built(i - 1, i, 0);
            built(i, i - 1, -a);
        }
        for(int i = 1; i <= m; i++){
            scanf("%d%d%d", &a, &b, &c);
            built(a - 1,  b, c);
        }
        int ans = spfa(0);
        if(ans == -1)
            printf("Bad Estimations\n");
        else
            printf("%d\n", ans);
    }
    return 0;
}

posted on 2018-11-22 09:19 坤sir 阅读(...) 评论(...) 编辑 收藏

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kunsir_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值