“Damn Single (单身狗)” is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID’s which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID’s of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.
Output Specification:
First print in a line the total number of lonely guests. Then in the next line, print their ID’s in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.
Sample Input:
3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333
Sample Output:
5
10000 23333 44444 55555 88888
#include<iostream>
#include<vector>
#include<set>
using namespace std;
const int maxn=100000;
vector<int>v(maxn);
int main(){
int n,m;
scanf("%d",&n);
int a,b;
for(int i=0;i<maxn;i++){
v[i]=-1;
}
for(int i=0;i<n;i++){//v里面装自己的对象,没对象的装-1
scanf("%d%d",&a,&b);
v[a]=b;
v[b]=a;
}
scanf("%d",&m);
vector<int>guest(m);
set<int>ass;
vector<int>isExist(maxn);
for(int i=0;i<m;i++){//guest里面装来的客人的ID
scanf("%d",&guest[i]);
/*
下一步不能直接把guest放进ass,因为还要判断他对象在不在guest里面,虽然有对象,但题目要求对象不在就算单身。
v[guest[i]]!=-1表示guest[i]有对象,而isExist[v[guest[i]]]=1;就表示 guest[i]这个人的对象在guest名单里面,(他本身其实还是-1)而不是他自己在名单里面。
这点一定要弄清!
*/
if(v[guest[i]]!=-1)
isExist[v[guest[i]]]=1;
}
for(int i=0;i<m;i++){//本来直接对isExist做遍历也可以,但是这题要求排序,所以还是用sort
if(isExist[guest[i]]!=1) ass.insert(guest[i]);//上个循环是对guest的对象赋1,这里是对guest本人进行遍历和判断!!
}
printf("%d\n",ass.size());
for(auto it=ass.begin();it!=ass.end();it++){
if(it!=ass.begin()) printf(" ");
printf("%05d",*it);
}
return 0;
}