poj2752_Seek the Name,Seek the Fame_KMP(next数组定义的应用)








Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18919 Accepted: 9712

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5


题意:让你找一个串中相等的前后缀的长度,按从小到大输出。

解答:

这题比较巧妙的用用了KMP的next数组的定义,看来自己还是没有掌握到KMP的精髓。因为next数组的存数的原理是走到当前字符时,此字符之前的前缀子串里相等的前缀和后缀(有重叠)的最大长度+1,如此可见,只要保证p [ next [ pl ] ]==p [ pl - 1 ] ,那么对于整个串来说,前缀和后缀就是相等的了。

PS:G++ WA了好多遍,C++ 一教就过了。。。为什么。。。



代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cstdlib>
using namespace std;
const int maxn=1e6+5;
int pl;char p[maxn];int next1[maxn];int a[maxn];
void get_next()
{
    int k=-1,j=0;
    next1[0]=-1;
    while(j<pl)
    {
        if(k==-1||p[j]==p[k])
        {
            j++;k++;
            next1[j]=k;
        }
        else
        k=next1[k];
    }
}

int main()
{
    while(scanf("%s",p)==1)
    {
        pl=strlen(p);
        get_next();
        int ans=0;
        int i=pl-1;
        while(next1[i]>-1){
        if(p[next1[i]]==p[pl-1]){a[ans]=next1[i]+1;ans++;}
        i=next1[i];
        }
        a[ans]+=pl;//加上串本身的长度
        sort(a,a+ans);
        for(int i=0;i<=ans;i++)
        printf("%d ",a[i]);
        printf("\n");
        memset(p,0,sizeof(p));
        memset(next1,0,sizeof(next1));
        memset(a,0,sizeof(a));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值