HDU-3711 Binary Number(贪心)

24 篇文章 0 订阅
11 篇文章 0 订阅

HDU-3711 Binary Number(贪心)

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Problem Description
For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.

Input
The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.

Output
For each test case you should output n lines, each of which contains the result for each query in a single line.

Sample Input
2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353

Sample Output
1
2
1
1
1
9999
0

题意:有A、B两个集合,B集合每个元素都能在A集合里面找到使得f(ai,bi)【两数异或之后的二进制 1的个数】最小的一个元素ai,直接贪心。

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <ctime>
#include <set>
#include <map>
#include <cmath>
using namespace std;
#define pi 3.14159265359
typedef long long LL;
const int maxn = 110;
int n, t, m, ma, maa;
int a[maxn],b[maxn];
int b_f(int x){
    int sum = 0;
    while(x){
        sum += x%2;
        x/=2;
    }
    return sum;
}
int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d %d",&n,&m);
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        for(int i=1;i<=m;i++){
            scanf("%d",&b[i]);
            ma = 99999999;
            maa = a[1];
            for(int j=1;j<=n;j++){
                int temp = b_f( a[j]^b[i] );
                if(ma > temp){
                    ma = temp;
                    maa = a[j];
                }
                if(ma==temp){
                    maa = a[j] < maa ? a[j] : maa;
                }   
            }
            printf("%d\n",maa);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值