HDU 3711 D - Binary Number

Description
For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.

Input
The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.

Output
For each test case you should output n lines, each of which contains the result for each query in a single line.

Sample Input
2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353

Sample Output
1
2
1
1
1
9999
0

在A里面找到一个数使得它和B里面的数二进制化时不一样的位数最大,如果有多个答案,取最小值,模拟。

代码:


#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int a[105];  
int count(int a)  
{  
    int ans = 0;  
    for(;a;a>>=1) if(a&1) ans++;  
    printf("ans=%d\n",ans);
    return ans;  
}  
int main()  
{  
    int b, i, j, n, m, k, minn, t,cas;  
    scanf("%d",&cas);  
    while(cas--)  
    {  
        scanf("%d%d",&n,&m);  
        for(i=0; i<n; i++) 
        scanf("%d",&a[i]);  
        for(i=0; i<m; i++)  
        {  
            scanf("%d",&b);  
            minn = count(b^a[0]);  
            k = 0;  
            for(j=1; j<n; j++)  
            {  
                t = count(b^a[j]);  
                if(t<minn||t==minn&&a[j]<a[k])  
                    { minn = t;k = j;}  
            }  
            printf("%d\n",a[k]);  
        }  
    }  
    return 0;  
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值