PAT(甲) 1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

直接在建树的过程中进行invert。然后正常层序以及中序遍历,为了照顾输出格式,建立两个vector数组,保存层序以及中序数据。

#include<iostream>

#include<algorithm>

#include<vector>

#include<queue>

using namespace std;

 

const int maxn = 14;

vector<int> ldata, indata;

 

struct node{

    int val;

    int lchild, rchild;

};

 

vector<node> nodelist;

void level_travl(int root){

    if(root != -1){

        queue<int> q;

        q.push(root);

        while(!q.empty()){

            int node = q.front();

            ldata.push_back(nodelist[node].val);

            q.pop();

            if(nodelist[node].lchild != -1)

                q.push(nodelist[node].lchild);

            if(nodelist[node].rchild != -1)

                q.push(nodelist[node].rchild);

        }   

    }

}

 

void in_travl(int root){

    if(root != -1){

        in_travl(nodelist[root].lchild);

        indata.push_back(nodelist[root].val);

        in_travl(nodelist[root].rchild);

    }   

}

 

int main(){

    int n, val, temp, root;

    char c, d;

    cin >> n;

    nodelist.resize(n);

    int data[n] = {0};

    for(int i = 0; i < n; i++){

        cin >> c >> d;

        nodelist[i].val = i;

        if(c != '-'){

            temp = c - '0';

            nodelist[i].rchild = temp;

            data[temp]++;

        } else {

            nodelist[i].rchild = -1;

        }

        if( d != '-'){

            temp = d - '0';

            nodelist[i].lchild = temp;

            data[temp]++;

        } else {

            nodelist[i].lchild = -1;

        }

    }

    for(int i = 0; i < n; i++){

        if(data[i] == 0){

            root = i;

            break;

        }

    }

    level_travl(root);

    in_travl(root);

    bool is_first = true;

    for(int i = 0; i < n; i++){

        if(is_first == true){

            cout << ldata[i];

            is_first = false;

        } else{

            cout << " " << ldata[i];

        }

    }

    cout << endl;

    is_first = true;

    for(int i = 0; i < n; i++){

        if(is_first == true){

            cout << indata[i];

            is_first = false;

        } else{

            cout << " " << indata[i];

        }

    }

    return 0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值