PAT(甲) 1121 Damn Single (25 分)

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

思路:利用二维mark数组,建立couple之间关系;利用flag数组,记录待test数据,每输入一个数据,couple均加1,这样最后输入完数据后,记录couple的flag数组数据为2,而无couple的为1。

#include<iostream>

#include<algorithm>

#include<vector>

using namespace std;

 

const int maxn = 100004;

vector<int> mark(maxn);

 

bool cmp(int a, int b){

    return a < b;

}

 

int main(){

    // freopen("F:\\PAT test\\test.txt","r",stdin);

    int n, m;

    cin >> n;

    int t1, t2;

    for(int i = 0; i < n; i++){

        cin >> t1 >> t2;

        mark[t1] = t2;

        mark[t2] = t1;

    }

    cin >> m;

//  int cnt = 0,

    int temp;

    vector<int> ans, temp_ans;

    int flag[maxn] = {0};

    for(int i = 0; i < m; i++){

        cin >> temp;

        flag[temp]++;

        flag[mark[temp]]++;

        temp_ans.push_back(temp);

    }

    for(int i = 0; i < temp_ans.size(); i++){

        if(flag[temp_ans[i]] != 2){

            ans.push_back(temp_ans[i]);

        }

    }

    cout << ans.size() << endl;

    sort(ans.begin(), ans.end(), cmp);

    for(int i = 0; i < ans.size(); i++){

        if(i == 0){

            printf("%05d", ans[i]);

        }else{

            printf(" %05d", ans[i]);

        }

    }

    return 0;

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值