PAT甲级1121 Damn Single (25 分)

1121 Damn Single (25 )

"Damn Single (单身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 50,000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (≤ 10,000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333

Sample Output:

5
10000 23333 44444 55555 88888

      题目大意:

给出n对出席的情侣随后给出长度为m的出席人员名单,找出单身狗,并且输出单身狗的数量以及从小到大输出id。

思路:

         由于即便他是情侣,也有可能由于情侣没有出席而变成单身狗。那么直接令所有id都增加1,使id从(1~ 1000000)然后用一个map<int, int> couple记录,如果发现某人的情侣是0 那么一定是单身狗,或者他情侣,但是arr[cpid] == false, 那也是单身狗。

         又是id排序,就用set咯,读入出席名单的时候,就可插入set咯,最后输出即可。

参考代码:

 

 

#include<set>
#include<map>
#include<cstdio>
#include<vector>
using namespace std;
map<int, int> cp;
bool arr[1000010];
vector<int> list;
int n, m, a, b;
set<int> ans;
int main(){
	scanf("%d", &n);
	for(int i = 0; i < n; ++i){
		scanf("%d%d", &a, &b);
		cp[a + 1] = b + 1; cp[b + 1] = a + 1;
	}
	scanf("%d", &m);
	list.resize(m);
	for(int i = 0; i < m; ++i){
		scanf("%d", &list[i]);
		arr[list[i] + 1] = true;
	}
	for(int i = 0; i < m; ++i){
		if(!cp[list[i] + 1]) ans.insert(list[i]);
		else if(!arr[cp[list[i] + 1]]) ans.insert(list[i]);
	}
	printf("%d\n", ans.size());
	for(auto it = ans.begin(); it != ans.end(); ++it)
		if(it == ans.begin()) printf("%05d", *it);
		else printf(" %05d", *it);
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值