9.1
Input Specification:
Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 10^9 is the decimal number and 2 <= b <= 10^9 is the base. The numbers are separated by a space.
Output Specification:
For each test case, first print in one line “Yes” if N is a palindromic number in base b, or “No” if not. Then in the next line, print N as the number in base b in the form “ak ak-1 … a0”. Notice that there must be no extra space at the end of output.
Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1
样例输入:
27 2
样例输出:
Yes
1 1 0 1 1
#include<stdio.h>
int main()
{
int N, b, i,j; int a[100];
scanf("%d%d", &N, &b);
if (N == 0)
printf("Yes\n0");
else
{
for (i = 0; N != 0; i++)
a[i] = N % b, N = N / b;
for (j = 0; j < i; j++)
{
if (a[j] != a[i - 1 - j])
break;
}
if (j == i)//注意这里是两个等于,只写一个等于的话就是把i-赋值给j的意思,导致结果全部输出Yes
printf("Yes\n");
else
printf("No\n");
for (i - 1; i - 1 > 0; i--)//倒序输出
printf("%d ", a[i - 1]);
printf("%d", a[0]);
}
system("pause");
return 0;
}