C语言编程100题-5.8

5.8
Given N rational numbers in the form “numerator/denominator”, you are supposed to calculate their sum.
Input Specification: Each input file contains one test case. Each case starts with a positive integer N (<=100), followed in the next line N rational numbers “a1/b1 a2/b2 …” where all the numerators and denominators are in the range of “long int”. If there is a negative number, then the sign must appear in front of the numerator.
Output Specification: For each test case, output the sum in the simplest form “integer numerator/denominator” where “integer” is the integer part of the sum, “numerator” < “denominator”, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.
Sample Input 1:
5
2/5
4/15
1/30
-1/30
8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3
2/3
Sample Output 2:
2
Sample Input 3:
3
1/3
-1/6
1/8
Sample Output 3:
7/24
样例输入:
5
1/2
-1/2
1/2
1/2
-1/2
样例输出:
1/2

#include<stdio.h>
int main()
{
       int n,i,a[100];
       scanf("%d", &n);
       for (i = 0; i < 2 * n; i = i + 2)
              scanf("%d/%d", &a[i], &a[i + 1]);
       int m = a[1];
       for (i = 3; i < 2 * n; i = i + 2)//m为所有分母的乘积
              m = a[i] * m;
       for (i = 0; i < 2 * n; i = i + 2)//新的a[i]是通分后的分子
              a[i] = a[i] * (m / a[i + 1]);
       int sum=0;
       for (i = 0; i < 2 * n; i = i + 2)
              sum = sum + a[i];//求新分子之和
       int r, p, q;
       p = sum, q = m;
       if (p >= q)//最大公约数的欧几里德算法,得到最大公约数q
       {
              while (p%q != 0)
              {
                      r = p % q;
                      p = q, q = r;
              }
              sum = sum / q; m = m / q;//化简分数
              if (m == 1)//特殊情况,分母为1,只输出整数
                      printf("%d", sum);
              else
              {
                      int x, y; x = sum / m; y = sum % m;
                      printf("%d %d/%d", x, y, m);
              }
       }
       else
       {
              while (q%p != 0)
              {
                      r = q % p;
                      q = p, p = r;
              }
              sum = sum / p; m = m / p;
              printf("%d/%d", sum, m);
       }
       system("pause");
       return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值