hdu 1757 A Simple Math Problem

A Simple Math Problem
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
Output
For each case, output f(k) % m in one line.
Sample Input

10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0

Sample Output

45
104

题目意思还是很清晰,刚开始觉得会超时,但是没有。
看着写的

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define ll long long
#define N 18
#define M 10
ll n, m;
struct mtx{
    int x[N][N];
};
mtx uni, ini;
void init()
{
    memset( ini.x, 0, sizeof( ini.x ));
    for( int i = 1 ; i < M ; i ++ ){
        ini.x[i][i-1] = 1;
    }
    memset( uni.x, 0, sizeof( uni.x ));///
    for( int i = 0 ; i < M ; i ++ ){///
        uni.x[i][i] = 1;
    }
}
mtx g_m( mtx a, mtx b )
{
    mtx c;
    for( int i = 0 ; i < M ; i ++ ){
        for( int j = 0 ; j < M ; j ++ ){
            c.x[i][j] = 0;
            for( int k = 0 ; k < M ; k ++ ){
                c.x[i][j] += (a.x[i][k] * b.x[k][j]) % m;
            }
            c.x[i][j] %= m;
        }
    }
    return c;
}
mtx s_m( mtx a , mtx b , int t )
{
    t %= m;
    while( t ){
        if( t & 1 ) b = g_m( a , b );
        a = g_m( a, a );
        t >>= 1;
    }
    return b;
}
int main()
{
    freopen( "in.txt", "r", stdin );
    while( scanf( "%d%d", &n, &m ) != EOF ){//cout<<n<<" "<<m<<endl;
        init();
        for( int i = 0 ; i < M ; i ++ ){
            scanf( "%d", &ini.x[0][i] );
        }
        if( n < M ){
            printf( "%d\n", n%m );
        }
        else{
            mtx ant = s_m( ini, uni, n-9 );///
            int sum = 0;
            for( int i = 0 ; i < M ; i ++ ){
                sum += ( ant.x[0][i] * (9-i) ) % m;///
            }
            printf( "%d\n", sum%m );
        }
    }
    return 0;
}

模版一个模版

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值