Hdu 1757 A Simple Math Problem

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5659    Accepted Submission(s): 3459


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
 
 
10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0

 
Sample Output
 
 
45
104



#include <iostream>
#include <string.h>
using namespace std;
int m;
void fun(int x[10][10], int y[10][10]){
    int z[10][10];
    memset(z, 0, sizeof(z));
    for(int i = 0; i < 10; i++){
        for(int j = 0; j < 10; j++){
            for(int l = 0; l < 10; l++){
                z[i][j]=(x[i][l]*y[l][j]+ z[i][j]) % m;
            }
        }
    }
    for(int i = 0; i < 10; i++){
        for(int j = 0; j < 10; j++){
            x[i][j] = z[i][j];
        }
    }
    return;
}

int main()
{
    int k;
    int a[10][10], t[10][10];
    while(scanf("%d%d", &k, &m) != EOF){
        memset(a, 0, sizeof(a));
        for(int i = 0; i < 10; i++){
            scanf("%d", &a[i][0]);
            if(i < 9){
                a[i][i+1] = 1;
            }
        }
        if(k >= 10){
            memset(t, 0, sizeof(t));
            for(int i = 0; i < 10; i++){
                t[i][i] = 1;
            }
            k = k - 9;
            while(k){
                if(k & 1){
                    fun(t, a);
                }
                fun(a, a);
                k /= 2;
            }
            int res = 0;
            for(int i = 0; i < 10; i++){
                res = ((9 - i)*t[i][0] +res)%m;
            }
            printf("%d\n", res);
        }
        else{
            int res = k % m;
            printf("%d\n", res);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值