hdu_1398_Square Coins(母函数)

Square Coins

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12884 Accepted Submission(s): 8852

Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, …, and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input

2
10
30
0

Sample Output

1
4
27

Source
Asia 1999, Kyoto (Japan)


题意:给出一个数n,计算出1到17的平方这些数中,组成n的方法有多少。


刚开始看到n最大是300,也没有开始学母函数,用了搜索,结果TLE了,附TLE代码。。。

#include <iostream>
#include <cstdio>
using namespace std;
#define N 21
int a[N], sum;
//int b[311];
void init()
{
    for( int i = 1 ; i < N ; i ++ ){
        a[i] = i * i;
    }
}

void dfs(int m, int k)
{
    if( m == 0 ){
        sum ++;
        return;
    }
    for( int i = k ; i <= 17 ; i ++ ){
        if( m - a[i] >= 0 )
            dfs( m-a[i], i );
        else
            return;
    }
}
//void surf()
//{
//    for( int i = 1 ; i < 311 ; i ++ ){
//        sum = 0;
//        dfs( i, 1 );
//        b[i] = sum;//cout<<b[i]<<endl;
//    }
//}
int main()
{
    freopen( "in.txt", "r", stdin );
    init();
//    surf();
    int n;
    while( scanf( "%d", &n ) != EOF ){
        if( n == 0 ) break;
        sum = 0;
        dfs( n, 1 );
        cout<<sum<<endl;
//        cout<<b[n]<<endl;
    }
    return 0;
}

之后看了母函数代码,看了挺久,emmmmm
勉强以自己的方式理解了,也不知道是不是理解错了。

母函数代码:

#include <iostream>
#include <cstdio>
using namespace std;
#define N 311
int n, m[21];
int c1[N], c2[N];
int main()
{
    freopen( "in.txt", "r", stdin );
    for( int i = 0 ; i <= 17 ; i ++ ){
        m[i] = i * i;
    }

    while( scanf("%d", &n) != EOF ){
    //while( ~scanf( "%d", &n ) & n ){
        if( n == 0 ) break;
        for(int i = 0 ; i <= n ; i ++ ){
            c1[i] = 0;
            c2[i] = 0;
        }
        c1[0] = 1;
        for(int i = 1 ; i <= 17 ; i ++ ){
            for(int j = 0 ; j <= n ; j ++ ){
                for(int k = 0 ; j+k*m[i] <= n ; k ++ )
                    c2[j+k*m[i]] += c1[j];
            }
            for(int j = 0 ; j <= n ; j ++ ){
                c1[j] = c2[j];
                c2[j] = 0;
            }
        }
        cout<< c1[n] << endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值