Matrix(二维树状数组)

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 24623 Accepted: 9116

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng

//AC代码:
#include <iostream>
#include <cstdio>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <utility>
#include <algorithm>
using namespace std;

const int maxn = 1100;
int C[maxn][maxn];  //树状数组

int n, t;

inline int lowbit(int x)  //上一波解释:inline(内联函数)省时间的好方法~\(≧▽≦)/~啦啦啦~~
{
    return x & (-x);
}

void update(int x, int y)
{
    for (int i=x; i<=n; i+=lowbit(i))
    {
        for (int j=y; j<=n; j+=lowbit(j))
        {
            C[i][j]++;  //咦, 只要把每次变化的矩阵打印粗来(快点看下面~)就阔以理解这个函数啦~
        }
    }
}

/*
这里上一波解释, 语言表达不喜勿喷╮(╯▽╰)╭~
算哒, 就按照大神讲的那样举一个栗子粗来阔以减少表达的难度:
假设一个矩形是(2, 3)和(5, 5), 另一个矩形是(2, 5)和(5, 7), 要查询(3, 5)这个点, 那sum+的是(2, 4)和(2, 5)的树状数组的值
这就是所谓的加上前缀和在本题的作用^_^, 亲, 记得模2哦~
*/
int query(int x, int y)
{
    int sum = 0;
    for (int i=x; i>0; i-=lowbit(i))
    {
        for (int j=y; j>0; j-=lowbit(j))
        {
            sum += C[i][j];  //想一下如果是两个矩形变化的情况;
        }
    }
    return sum % 2;
    //return C[i+lowbit(i)][j+lowbit(j)] % 2;
}

int main()
{
    int x;
    string s;
    int a, b, c, d;
    scanf("%d", &x);
    while (x--)
    {
        memset(C, 0, sizeof(C));
        scanf("%d%d", &n, &t);
        while (t--)
        {
            s.clear ();
            cin >> s;
            if (s == "C")
            {
                scanf("%d%d%d%d", &a, &b, &c, &d);
                update(a, b);
                /*for (int i=1; i<=n; i++)    //打印中间变化的矩阵……阔以帮助理解的说~~
                {
                    for (int j=1; j<=n; j++)
                    {
                        cout << C[i][j] << " ";
                    }
                    cout << endl;
                }
                cout << endl;*/
                update(a, d+1);  //要注意加1(⊙o⊙)哦~
                /*for (int i=1; i<=n; i++)
                {
                    for (int j=1; j<=n; j++)
                    {
                        cout << C[i][j] << " ";
                    }
                    cout << endl;
                }
                cout << endl;*/
                update(c+1, b);
                /*for (int i=1; i<=n; i++)
                {
                    for (int j=1; j<=n; j++)
                    {
                        cout << C[i][j] << " ";
                    }
                    cout << endl;
                }
                cout << endl;*/
                update(c+1, d+1);
                /*for (int i=1; i<=n; i++)
                {
                    for (int j=1; j<=n; j++)
                    {
                        cout << C[i][j] << " ";
                    }
                    cout << endl;
                }
                cout << endl;*/
            }
            if (s == "Q")
            {
                scanf("%d%d", &a, &b);
                cout << query(a, b) << endl;
            }
        }
        if (x != 0)
        {
            cout << endl;
        }
    }
    return 0;
}

树状数组学了没多久, 还不会用就啪叽啪叽的去学二维的, 好了吧, 结果大脑不够用,第一次被大神手把手教, (⊙v⊙)嗯, 感觉就是自己好蠢的 ~~
感觉自己现在的水平有点hold不住这样的题, 反正现在是不敢做第二道这样的题了, 我该说点什么呢,哎 ╮(╯▽╰)╭, 自己好菜啊~
顺便说一下, matrix是我所崇拜的一个人的名字, 哎吗, 自己和偶像差距……还是不要想了 ……
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值