Max Sum Plus Plus HDU - 1024(DP+m子段最大和)

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n
Process to the end of file. 

Output

Output the maximal summation described above in one line. 

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8

#include<cstdio>
#include<cstring> 
#include<iostream>
#include<algorithm>

using namespace std;

const int INF = 0x3f3f3f3f;
const int maxn = 1e6 + 10;

int dp[maxn], w[maxn], a[maxn];

int read() {
	int f = 1, num = 0;
	int c = getchar();
	while (c < '0' || c > '9') {
		if (c == '-') f = -1;
		c = getchar();
	}
	while (c >= '0' && c <= '9') {
		num = (num << 3) + (num << 1) + c - 48;
		c = getchar();
	}
	return f*num;
}

int main(void) {
	
	int m, n;
	while (~scanf("%d %d", &m, &n)) {
		
		for (int i = 1; i <= n; ++i) {
			a[i] = read(), dp[i] = w[i] = 0;
		}
		//memset(dp, 0, sizeof(dp));  //慢了 
		//memset(w, 0, sizeof(w));
		int premax;
		for (int i = 1; i <= m; ++i) {
			premax = -INF;
			for (int j = i; j <= n; ++j) {
				
				dp[j] = max(dp[j-1], w[j-1]) + a[j];
				w[j-1] = premax;
				premax = premax > dp[j] ? premax : dp[j];
				
			}
			
		}
		printf("%d\n", premax);
	}
	
	return 0;
} 

参考1

好参考

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值