Subsequence POJ - 3061 尺取法

Subsequence

 POJ - 3061 

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

题意:求最短区间,使得区间和大于等于S,输出区间长度,没有的话输出0

尺取

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int INF = 0x3f3f3f3f;

int a[100007];
int main() {
	
	int t;
	scanf ("%d", &t);
	while (t--) {
		int n, s;
		scanf ("%d %d", &n, &s);
		for (int i = 1; i <= n; ++i) {
			scanf ("%d", &a[i]);
		}
		int ans = INF;
		int head = 0, sum = 0;
		for (int tail = 1; tail <= n; sum -= a[tail++]) {
			while (head < n && sum < s) sum += a[++head];
			if (sum < s) break;
			ans = min(ans, head - tail + 1);
		}
		if (ans != INF)
			printf ("%d\n", ans);
		else puts("0");
	}
	
	return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值