(蓝桥杯)试题 算法训练 排列

试题 算法训练 排列

资源限制
时间限制:1.0s 内存限制:256.0MB
  排列
问题描述
  给定一个N,输出N的所有排列中按字典序排名的第M个.
输入格式
  共一行.两个数为N,M.
输出格式
  共一行.为N的一个排列.
样例输入
3 3
样例输出
2 1 3
数据规模和约定
  N<=9.

import java.util.Scanner;

public class Main {
    public static int count  = 0;
    public static void permutation(String prefix, char [] arr, int M){
        if(prefix.length() == arr.length){
            count ++ ;
            if(count == M){
                for(int i=0; i<prefix.length(); i++){
                    System.out.print(prefix.charAt(i) + " ") ;
                }
                System.exit(0) ;
            }
        }
        for(int i=0; i<arr.length; i++){
            char c = arr[i] ;
            if(f(arr,c) > f(prefix.toCharArray(),c)) {
                permutation(prefix + c, arr, M);
            }
        }
    }
    public static int f(char [] arr, char c){
        int sum = 0 ;
        for(int i=0; i<arr.length; i++){
            if(c == arr[i]){
                sum ++ ;
            }
        }
        return sum ;
    }
    public static void main(String[] args){
        Scanner input = new Scanner(System.in);
        int N = input.nextInt() ;
        int M = input.nextInt() ;
        String s = "" ;
        for(int i=1; i<=N; i++){
            s += i ;
        }
        permutation("", s.toCharArray(), M) ;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

nuist__NJUPT

给个鼓励吧,谢谢你

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值