Z型打印二维数组(模拟)

Z型打印二维数组

在这里插入图片描述
样例输入:
3 4
1 2 3 4
5 6 7 8
9 10 11 12

样例输出:
1 2 5 9 6 3 4 7 10 11 8 12

算法思想:本题打印数组分为从左往右和从右往左,若为从左往右,则考虑三种情况,若是从右往左,则也考虑三种情况。

import java.util.Scanner;

public class PrintArray {
    public static void print(int [][] matrix){
        int r = 0, c = 0 ;
        int m = matrix.length, n = matrix[0].length ;
        boolean leftToRight = true ; //标记从左到右
        while(r < m && c < n){
            if(leftToRight){ //从左往右走
                System.out.print(matrix[r][c] + " ") ;
                if(r == 0 && c < n - 1){
                    leftToRight = !leftToRight ;
                    c ++ ;
                    continue ;
                }else if(r > 0 && c == n - 1){
                    leftToRight = !leftToRight ;
                    r ++ ;
                    continue ;
                }else{
                    r -- ;
                    c ++ ;
                }
            }else{ //从右往左走
                System.out.print(matrix[r][c] + " ") ;
                if(c == 0 && r < n - 1){
                    leftToRight = !leftToRight ;
                    r ++ ;
                    continue ;
                }else if(r == m -1 && c < n-1){
                    leftToRight = !leftToRight ;
                    c ++ ;
                    continue ;
                }else{
                    r ++ ;
                    c -- ;
                }
            }
        }
    }
    public static void main(String[] args) {
        Scanner input = new Scanner(System.in) ;
        int m = input.nextInt() ;
        int n = input.nextInt() ;
        int [][] matrix = new int [m][n] ;
        for(int i=0; i<m; i++){
            for(int j=0; j<n; j++){
                matrix[i][j] = input.nextInt() ;
            }
        }
        print(matrix) ;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

nuist__NJUPT

给个鼓励吧,谢谢你

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值