1039 Course List for Student 25

1039 Course List for Student 25

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N ( ≤ 40 , 000 ) N (≤40,000) N(40,000), the number of students who look for their course lists, and K ( ≤ 2 , 500 ) K (≤2,500) K(2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 1 1 to K K K) in the following format: for each course i i i, first the course index i i i and the number of registered students N i ( ≤ 200 ) N_i(≤200) Ni(200) are given in a line. Then in the next line, N i N_i Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N N N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N N N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

问题思路

本题大意:输入课程的学生列表,然后查询学生的课程列表。

问题关键在于如何建立学生名字name和课程列表course list的数据结构。

思路一戳我看源码

以学生名字name为键course list为值建立一个map,查询时间复杂度为 O ( l o g N ) O(logN) O(logN)

思路一戳我看源码

name进行哈希,把cousre list储存在一个哈希表中,查询时间复杂度为 O ( 1 ) O(1) O(1)

注意! 大容量哈希表定义在栈区(main()里面)可能会导致堆栈溢出,所以最好将其定义在静态变量区(main()外面)。

源码

#include <iostream>
#include <cstdio>
#include <vector>
#include <string>
#include <map>
#include <algorithm>
using namespace std;

int main()
{
    int N, K;
    scanf("%d %d", &N, &K);

    map<string, vector<int>> students;
    auto ptrs = students.begin();

    string input_name;
    char cname[5];

    int index, n;
    for (int i = 0; i < K; i++)
    {
        scanf("%d %d", &index, &n);
        for (int i = 0; i < n; i++)
        {
            scanf("%s", cname);
            input_name = cname;
            if ((ptrs = students.find(input_name)) == students.end())
            {
                students[input_name] = vector<int>({index});
            }
            else
            {
                ptrs->second.push_back(index);
            }
        }
    }
    for (int i = 0; i < N; i++)
    {
        scanf("%s", cname);
        input_name = cname;
        ptrs = students.find(input_name);
        if (ptrs == students.end())
        {
            printf("%s 0\n", input_name.c_str());
        }
        else
        {
            sort(ptrs->second.begin(), ptrs->second.end());
            printf("%s %d", ptrs->first.c_str(), ptrs->second.size());
            for (auto s = ptrs->second.begin(); s != ptrs->second.end(); s++)
            {
                printf(" %d", *s);
            }
            putchar('\n');
        }
    }

    return 0;
}

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

int hashString(char str[])
{
    int id = 0;
    for (int i = 0; i < 3; i++)
    {
        id = id * 26 + str[i] - 'A';
    }
    id = id * 10 + str[3] - '0';
    return id;
}

// 大数组要定义在main()外部,否则会导致main()栈帧溢出
const int M = 26*26*26*10;
vector<int> students[M];

int main()
{

    int N, K;
    scanf("%d %d", &N, &K);

    int index, n, id;
    char cname[5];
    for (int i = 0; i < K; i++)
    {
        scanf("%d %d", &index, &n);
        for (int i = 0; i < n; i++)
        {
            scanf("%s", cname);
            id = hashString(cname);
            students[id].push_back(index);
        }
    }
    for (int i = 0; i < N; i++)
    {
        scanf("%s", cname);
        id = hashString(cname);
        if (students[id].size() == 0)
        {
            printf("%s 0\n", cname);
        }
        else
        {
            sort(students[id].begin(), students[id].end());
            printf("%s %d", cname, students[id].size());
            for (auto s = students[id].begin(); s != students[id].end(); s++)
            {
                printf(" %d", *s);
            }
            putchar('\n');
        }
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值