HDU 1116 Play on Words 欧拉道路

F - Play on Words
Time Limit:5000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 
 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list. 
 

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 
 

Sample Input

 
    
3 2 acm ibm 3 acm malform mouse 2 ok ok
 

Sample Output

 
    
The door cannot be opened. Ordering is possible. The door cannot be opened.

题意,给你一系列单词,首尾字母相同可相连,问能否把其全部连起来(一条链或一个环)


思路:按首尾字母建立图,判断是否存在欧拉道路或欧拉回路,


定义:

  图G的一个回路,若它恰通过G中每条边一次,则称该回路为欧拉(Euler)回路。
  如果一个图只是形成一个连通所有节点的链,且每一点只走一次,则成为欧拉道路。

先用并查集判断是否连通,不连通一定不可能构成欧拉道路,然后判断是否少于等于一个点,出度=入度+1(首),入度=出度+1(尾)。


上星期一共才做了两道题,还全遇到了迷之BUG。。TT,这道题改了一下午没改对,晚上花十几分钟重新写了一遍就过了。。真是神奇

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<cstdlib>
#include<cmath>
#include<queue>
using namespace std;

int par[30];
int find(int x){
	if(x==par[x])
	   return x;
	else return  x=find(par[x]);
}

void Union(int x,int y){
	x=find(x);//比赛时就是这写错了,把根接在另一个上 
	y=find(y);
	par[x]=y;
}

int main(){
//	freopen("input.txt","r",stdin);
	int t;
	char s[1004];
	scanf("%d",&t);
	int Begin[30],End[30],flag[30];
	while(t--){
		memset(Begin,0,sizeof(Begin));
		memset(End,0,sizeof(End));
		memset(flag,0,sizeof(flag));
		for(int i=0;i<30;i++){
			par[i]=i;
		}
		int n;
		scanf("%d",&n);
		for(int i=0;i<n;i++){
			scanf("%s",s);
			int x=s[0]-'a';
			int y=s[strlen(s)-1]-'a';
			flag[x]=1;
			flag[y]=1;
			Begin[x]++;//出度 
			End[y]++;//入度 
			Union(x,y);
		}
		int gen=0;
		for(int i=0;i<26;i++){
			if(flag[i] && i==find(i)){
				gen++;
			}
		}
		if(gen>=2){//只存在一个根,连通 
			printf("The door cannot be opened.\n");
			continue;
		}
		else{
			int a=0,b=0,fail=0;
			for(int i=0;i<26;i++){
				if(Begin[i]==End[i])
				   continue;
				else if(Begin[i]-End[i]==1)
				   a++;
				else if(End[i]-Begin[i]==1)
				   b++;
				else
				   fail=1;
			}
			if(fail==1 || a>=2 || b>=2 ){
				printf("The door cannot be opened.\n");
			}
			else
			    printf("Ordering is possible.\n");
		}
	}
	return 0;
}
//第一次,多组测试用例,没有初始化数组;
//第二次, 32行把begin写为了end; 
//第三次,出现runtime error(access ...),可能是数组越界,把s[]改大后就成wa了。。 
//第四次,没想到要判断连通,可能会出现这种情况,abc,cba,def,这种符合出度入度条件但不连通
//第五次,又出现了迷之BUG。。 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值