杭电-4310Hero(贪心)

Hero

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3375    Accepted Submission(s): 1513


Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
 

Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
 

Output
Output one line for each test, indicates the minimum HP loss.
 

Sample Input
  
  
1 10 2 2 100 1 1 100
 

Sample Output
  
  
20 201
 



先把攻击高的血少的,先打死,就是按攻击与血的比值排序!



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
	int hp,dps;
}s[50];
bool cmp(node x,node y)
{
	return (1.0*x.dps/x.hp)>(1.0*y.dps/y.hp);
}
int main()
{
	int a,b,m,n,i,j;
	while(scanf("%d",&n)!=EOF)
	{
		int sumdps=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&s[i].dps,&s[i].hp);
			sumdps+=s[i].dps;
		}
		int sum=0;
		sort(s,s+n,cmp);
		for(i=0;i<n;i++)
		{
			for(j=0;j<s[i].hp;j++)
				sum+=sumdps;
			sumdps-=s[i].dps;
		}
		printf("%d\n",sum);
	}
	return 0;
 }



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值