Wolf and Rabbit
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6445 Accepted Submission(s): 3212
Problem Description
There is a hill with n holes around. The holes are signed from 0 to n-1.
A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.
Input
The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
Output
For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
Sample Input
2 1 2 2 2
Sample Output
NO YES
你会发现一个规律,每次转完一圈的数和上一圈每个位置的数相比,都偏移了一个m%n,只有当每次偏移1的时候,才能全部都访问,否则兔子存活!
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int gcd(int x,int y)
{
int t;
while(y)
{
int t=y;
y=x%y;
x=t;
}
return x;
}
int main()
{
int m,a,b;
scanf("%d",&m);
while(m--)
{
scanf("%d%d",&a,&b);
if(gcd(a,b)==1)
printf("NO\n");
else
printf("YES\n");
}
return 0;
}