杭电-2674N!Again(大数阶乘)

20 篇文章 0 订阅
6 篇文章 0 订阅

N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4267    Accepted Submission(s): 2279


Problem Description
WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!
 

Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
 

Output
For each case, output N! mod 2009
 

Sample Input
  
  
4 5
 

Sample Output
  
  
24 120
 


大数阶乘,但是规律是41及其以后取余2009都为0,一定要优化这一句,否则超时



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
long long solve(long long  n)
{
	long long t=1;
	for(long long i=n;i>=2;i--)
		t=i*t%2009;
	return t;
}
int main()
{
	long long a,n,i;
	while(scanf("%lld",&n)!=EOF)
	{
		if(n>=41)
		printf("0\n");
		else
		{
			a=solve(n);
			printf("%lld\n",a);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值