杭电-1034Candy Sharing Game(模拟)

这是一篇关于杭电在线判题系统中编号为1034的Candy Sharing Game问题的解析。博客主要聚焦于模拟游戏过程中糖果分配的变化,通过详细的步骤模拟来阐述解题思路。
摘要由CSDN通过智能技术生成

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4434    Accepted Submission(s): 2705


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
 

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
 

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
 

Sample Input
  
  
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
 

Sample Output
  
  
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
 


模拟题,模拟每次变化的过程!



#include<cstdio>
#include<cstring>
#include<algorithm> 
#define N 1000100
using namespace std;
long long  a[N],b[N];
int main()
{
	long long m,n,i,j,cot,t,p;
	while(scanf("%lld",&m),m)
	{
		cot=0;
		for(i=1;i<=m;i++)
		{
			scanf("%lld",&a[i]);
			b[i]=a[i];
		}
			
		sort(b+1,b+m+1);//记得一定要用一个数组代替,因为我们不能改变原来人员的位置

		while(b[1]!=b[m])//当最大和最小值都相等的时候,所有的值就都相等了
		{
			t=a[m];
			for(i=1;i<=m;i++)
			{
				p=t/2+a[i]/2;
				t=a[i];
				a[i]=p;
				if(a[i]&1)
				a[i]++;
				b[i]=a[i];
			}
			sort(b+1,b+m+1);
			cot++;
		}
		printf("%lld %lld\n",cot,a[1]);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值