POJ 2891 Strange Way to Express Integers( EXGCD)

Strange Way to Express Integers
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 14407 Accepted: 4699

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1a2…, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1a2, …, ak are properly chosen, m can be determined, then the pairs (airi) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2
8 7
11 9

Sample Output

31

Hint

All integers in the input and the output are non-negative and can be represented by 64-bit integral types.

Source

【题目大意】

给出k个模方程组:x mod ai = ri。求x的最小正值。如果不存在这样的x,那么输出-1.

【题目分析】

由于这道题目里面的ai、ri之间不满足两两互质的性质,所以不能用中国剩余定理直接求解。

不过,我们可以模仿中国剩余定理的做法来解决这个问题。

如果只有一个方程:x mod a0 = r0。那么,显然x的最小正值为a0+r0。

根据模的性质,我们容易得知,x+a0*k均为该方程的解。(k为正整数)

如果多了一个方程:x mod a1 = r1。那么,我们为了使之间求得的解x0=a0+r0能够同时满足这两个方程,只好令x0=x0+a0*k,显然这样做x0仍然满足第一个方程。这时候我们相当于要求解这样一个模方程:(x0+a0*k) mod a1 = r1。这个方程我们可以用拓展欧几里得算法求得k的值。这样,只要令x0变成x0+a0*k,就能同时满足这两个方程了。

推而广之,对于方程x mod ai = ri,假如我们之前求得的解为X,那么我们要令X变成X+k*LCM(a0,a1,a2...ai-1),使得它满足这个方程。k我们可以用拓展欧几里得算法求解,LCM可以在每一次更新,这样就能在接近O(klogk)的时间复杂度内解决这个问题了。

无解的判断:若某个(X+k*LCM) mod ai = ri无整数解,那么原方程组无解。

该题虽然数据规模较大,但比较仁慈,所有ai的LCM是64位整型,所以不用使用高精度。


#include <iostream>
#include <stdio.h>

using namespace std;

long long int exgcd(long long int a,long long  int b,long long int& x,long long int& y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    else
    {
        long long int tmp=exgcd(b,a%b,x,y);
        long long int t=x;
        x=y;
        y=t-a/b*y;
        return tmp;
    }
}
long long int gcd(long long a,long long b)
{
    if(b==0)return a;
    else gcd(b,a%b);
}
int main()
{
    int n;
    long long x,y;
    while(~scanf("%d",&n))
    {
       int flag=0;
       long long int c;
       long long m1,r1;
       long long m2,r2;
        scanf("%lld%lld",&m1,&r1);
        for(int i=2; i<=n; i++)
        {
            scanf("%lld%lld",&m2,&r2);
            if(flag)continue;
            long long c=r2-r1;
            long long int d=exgcd(m1,m2,x,y);
            if(c%d)
            {
               flag=1;
            }
            else
            {
                long long t=m2/d;
                x=(c/d*x%t+t)%t;
                r1=m1*x+r1;
                m1=m1*m2/d;
            }
        }
        if(flag)printf("-1\n");
        else printf("%lld\n",r1);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值