POJ 2528 Mayor's posters(线段树+离散化)

Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 60691 Accepted: 17565

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

题目大意:

题意:在墙上贴海报,海报可以互相覆盖,问最后可以看见几张海报
思路:这题数据范围很大,直接搞超时+超内存,需要离散化:
离散化简单的来说就是只取我们需要的值来用,比如说区间[1000,2000],[1990,2012] 我们用不到[-∞,999][1001,1989][1991,1999][2001,2011][2013,+∞]这些值,所以我只需要1000,1990,2000,2012就够了,将其分别映射到0,1,2,3,在于复杂度就大大的降下来了
所以离散化要保存所有需要用到的值,排序后,分别映射到1~n,这样复杂度就会小很多很多
而这题的难点在于每个数字其实表示的是一个单位长度(并且一个点),这样普通的离散化会造成许多错误(包括我以前的代码,poj这题数据奇弱)
给出下面两个简单的例子应该能体现普通离散化的缺陷:
1-10 1-4 5-10
1-10 1-4 6-10
为了解决这种缺陷,我们可以在排序后的数组上加些处理,比如说[1,2,6,10]
如果相邻数字间距大于1的话,在其中加上任意一个数字,比如加成[1,2,3,6,7,10],然后再做线段树就好了.
线段树功能:update:成段替换 query:简单hash

AC代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

const int M=112345;
int L[M],R[M];
int S[M<<2];
bool Hash[M];
int col[M<<2];
int cnt;
void pushdown(int root)
{
    if(col[root]!=-1)
    {
        col[root<<1]=col[root<<1|1]=col[root];
        col[root]=-1;
    }
}
void updata(int b,int e,int c,int root,int l,int r)//b e为要查找的区间范围,l r为root的区间范围
{
    if(b<=l&&r<=e)
    {
        col[root]=c;
        return;
    }
    pushdown(root);
    int mid=(l+r)/2;
    if(mid>=e)
        updata(b,e,c,root<<1,l,mid);
    else if(mid<b)
        updata(b,e,c,root<<1|1,mid+1,r);
    else
    {
        updata(b,mid,c,root<<1,l,mid);
        updata(mid+1,e,c,root<<1|1,mid+1,r);
    }

}
void query(int l,int r,int root)
{
    if(col[root]!=-1)
    {
        if(!Hash[col[root]])cnt++;
        Hash[col[root]]=true;
        return;
    }
    if(l==r)return ;
    int mid=(l+r)/2;
    query(l,mid,root<<1);
    query(mid+1,r,root<<1|1);
}
int get(int k,int n)//获取离散化后的下标
{
    return lower_bound(S,S+n,k)-S;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int k=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&L[i],&R[i]);
            S[k++]=L[i];
            S[k++]=R[i];
        }
        sort(S,S+k);
       // for(int i=0; i<k; i++)printf("%d ",S[i]);printf("\n");
        int kk=1;
        for(int i=1; i<k; i++)
        {
            if(S[i]!=S[i-1])
                S[kk++]=S[i];
        }
        for(int i=kk-1; i>0; i--)
        {
            if(S[i]!=S[i-1]+1)S[kk++]=S[i-1]+1;
        }
        sort(S,S+kk);
        //for(int i=0; i<kk; i++)printf("%d ",S[i]);printf("\n");
        memset(col,-1,sizeof(col));
        for(int i=1; i<=n; i++)
        {
            int l=get(L[i],kk);
            int r=get(R[i],kk);
           // printf("l=%d r=%d\n",l,r);
            updata(l,r,i,1,0,kk);
        }
        cnt=0;
        memset(Hash,false,sizeof(Hash));
        query(0,kk,1);
        printf("%d\n",cnt);
    }
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值