C - Catch That Cow
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
#include<stdio.h>
#include<queue>
#include<stdlib.h>
#include<string.h>
using namespace std;
const int N = 200100;
int n, k;
struct node {
int x, step; //设置节点为当前节点的位置以及当前的步数
};
queue<node> q;
int vis[N];
void Bfs() {
int X,Step;
while(!q.empty()) {
node w2=q.front(); //Bfs从初状态开始,利用规则,生成下一层的状态,在下一层查找是否找到目标位置
q.pop(); //用循环条件队列非空,对每种状态的节点进行判断。这里获取每次判断节点的步数,以及当前位置信息
X=w2.x;
Step=w2.step;
if(X==k) { //这一步如果发现奶牛位置输出所用步数
printf("%d",Step);
return;
}
if(X>=1&&vis[X-1]==0) {
node w3;
vis[X-1]=1;
w3.x=X-1; //按照要求移动,利用节点记录步数位置
w3.step=Step+1;
q.push(w3);
}
if(X<=k&&vis[X+1]==0) {
node w3;
vis[X+1]=1;
w3.x=X+1;
w3.step=Step+1;
q.push(w3);
}
if(X<=k&&vis[X*2]==0) {
node w3;
vis[X*2]=1;
w3.x=X*2;
w3.step=Step+1;
q.push(w3);
}
}
}
int main() {
while(~scanf("%d %d",&n,&k)) {
while(!q.empty()) {
q.pop(); //这里将队列清空
}
memset(vis,0,sizeof(vis)); //这里将访问数组清空
vis[n]=1; //将农夫的位置设为初始值
node w; //即位置为5,步数为0,并将其入队
w.x=n;
w.step=0;
q.push(w);
Bfs(); // 执行Bfs
}
}