C - Catch That Cow(经典二维BFS)

C - Catch That Cow POJ - 3278

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

思路:经典的二维bfs,分三种情况,加一减一翻倍,注意要判断小于N 避免数组越界;不要忘了判断via避免超时。

代码:

#include <iostream>
#include <cstring>
#include <queue>

using namespace std;

typedef struct node {
    int x,step;
} ty;

int n,m;
int via[1000002];
int N = 1000000;
ty t,d;

int bfs()
{
    queue <ty> Q;
    t.x = n;
    t.step = 0;
    via[t.x] = 1;
    Q.push(t);

    while ( !Q.empty() ) {
        t = Q.front();
        Q.pop();

        if ( t.x==m ) {
            return t.step ;
        }

        d.x = t.x-1;            // 减一的情况
        d.step = t.step + 1;
        if ( d.x>=0 && via[d.x]==0 ) {
            via[d.x] = 1;
            Q.push(d);
        }


        d.x = t.x + 1;        // 加一的情况
        d.step = t.step + 1;
        if ( d.x<=N && via[d.x] == 0 ) {  // 小于N 避免无限放大,数组越界
            via[d.x] = 1;
            Q.push(d);
        }

        d.x = 2*t.x;           // 翻倍的情况
        d.step = t.step + 1;
        if ( d.x<=N && via[d.x] == 0 ) {
            via[d.x] = 1;
             Q.push(d);
        }
    }
    return -1;
}

int main()
{
    cin >> n >> m;
    memset(via,0,sizeof(via));
    int ans = bfs();

    cout << ans << endl;

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值