Ice_cream's world I(并查集找环)

Ice_cream's world I
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input

In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.

Output

Output the maximum number of ACMers who will be awarded. 
One answer one line.

Sample Input

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

Sample Output

3





说白了就是找  给的数据能组成多少个环;

#include<cstdio>
#include<cstdlib> 
int fu[10010];
void chu(int x)
{
	for(int i=0;i<x;i++){
		fu[i]=i;
	}
}

int root(int x)
{
	if(x!=fu[x]){
		fu[x]=root(fu[x]);
	}
	return fu[x];
}

bool Unioncmp(int x,int y)
{
	int fx=root(x);
	int fy=root(y);
	if(fx==fy){<span style="white-space:pre">	</span>//根节点相同说明就找到了一个环;
		return true;
	}else{
		fu[fx]=fy;
		return false;
	}
}

int main()
{
	int n,m,a,b;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		chu(n);
		int cont=0;
		for(int i=0;i<m;i++)
		{
			scanf("%d %d",&a,&b);
			//Unioncmp(a,b);
			if(Unioncmp(a,b))
			cont++;
		}
		printf("%d\n",cont);
	}
	return 0;
}

再来两个压缩路径模板:
int findroot(int x)
{
  int r=x;         
  while(r!=fa[r]) 
  r=fa[r]; 
  int i=x,j;      
  while(i!=r) {
   j=fa[i];fa[i]=r;i=j;
  }
 return r; 
}//循环实现压缩路径 



int findroot(int x)
{ 
 if(x==fa[x]) return x; 
 fa[x]=findroot(fa[x]); 
 return fa[x];
}//递归实现压缩路径 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值